Jump to content

Search the Community

Showing results for tags 'test'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • W3Schools
    • General
    • Suggestions
    • Critiques
  • HTML Forums
    • HTML/XHTML
    • CSS
  • Browser Scripting
    • JavaScript
    • VBScript
  • Server Scripting
    • Web Servers
    • Version Control
    • SQL
    • ASP
    • PHP
    • .NET
    • ColdFusion
    • Java/JSP/J2EE
    • CGI
  • XML Forums
    • XML
    • XSLT/XSL-FO
    • Schema
    • Web Services
  • Multimedia
    • Multimedia
    • FLASH

Calendars

  • Community Calendar

Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests


Languages

Found 5 results

  1. customer service?

    I was looking for a customer service contact, but didn't find it. If a teacher/school needs to pay for a few students to take a test, like HTML developer, how do we do that? is there a group deal? If I pay and get a code to take a test under my account, can a student make his/her own account and then use the code I'm sent? what am i missing?
  2. i want to test

    I want to know how much time is added to the last page.
  3. Critiques for games topic? Somehow?

    I was thinking it would be nice for people to be easily be able to play other people's games they made (using languages such as JavaScript) without telling them to copy-paste your code. I'd like to play what other people made. As long as its it not a virus code. The only problem is, how would you do it? I have no idea.
  4. New to Javascript. I am trying to show the selected value after the change so I can do some additional processing, but I cannot get my code to run. I am not sure my syntax is correct using java script.? <html> <head> <title>This is my test site</title> <script> function test(value) { value = document.getElementById("colorOption").selectedIndex; alert("document.getElementById("colorOption")[x].value); } </script> </head> <select id = "colorOption" name "colorOption" onchange = "test(value)"> <option value = 0>Red</option> <option value = 1>Green</option> <option value = 2>Blue</option> <option value = 3>Yellow</option> <option value = 4>Purple</option> </select>     </body> </html>
  5. I am trying to apply <href> links to only top root nodes of my tab navigation by testing for if they have child nodes. If they have children they should not get a link assigned to them, but I want all subsuquent parents (those in nested <ul> that have children) to have links. Here is the location of my test page: https://edit-www.rose-hulman.edu/offices-services/alumni-affairs-2.aspx You can see from the first tab dropdown the problem I am having. Under "Alumni Affairs", which has no link assigned to it, as it shouldn't, there is "Young Alumni Counsel" . This node needs to have a link assigned to it, but it won't ever get one because the xslt "choose" is not restrictive to the" / " node but applies to all the child nodes as well. So if I need to add any other nodes under any of child nodes they will no longer link to a page because they are now parents. Thanks for all your help. I am using the CMS Umbraco and ver. 1.0 xml. Here is my xslt: <?xml version="1.0" encoding="UTF-8"?><!DOCTYPE xsl:stylesheet [ <!ENTITY nbsp " "> ]><xsl:stylesheet version="1.0" xmlns:xsl="http://www.w3.org/1999/XSL/Transform" xmlns:msxml="urn:schemas-microsoft-com:xslt" xmlns:umbraco.library="urn:umbraco.library" xmlns:Exslt.ExsltCommon="urn:Exslt.ExsltCommon" xmlns:Exslt.ExsltDatesAndTimes="urn:Exslt.ExsltDatesAndTimes" xmlns:Exslt.ExsltMath="urn:Exslt.ExsltMath" xmlns:Exslt.ExsltRegularExpressions="urn:Exslt.ExsltRegularExpressions" xmlns:Exslt.ExsltStrings="urn:Exslt.ExsltStrings" xmlns:Exslt.ExsltSets="urn:Exslt.ExsltSets" exclude-result-prefixes="msxml umbraco.library Exslt.ExsltCommon Exslt.ExsltDatesAndTimes Exslt.ExsltMath Exslt.ExsltRegularExpressions Exslt.ExsltStrings Exslt.ExsltSets "><xsl:output method="xml" omit-xml-declaration="yes"/><xsl:param name="currentPage"/><xsl:template match="/"> <xsl:variable name="home" select="$currentPage/ancestor-or-self::Category2HomePage" /> <xsl:variable name="nav" select="$home/*[@isDoc and string(umbracoNaviHide)!=1]" /> <ul> <xsl:if test="string($home/useAlternateNavigation) = '1'"> <xsl:attribute name="class">alt-nav</xsl:attribute> </xsl:if> <xsl:for-each select="$nav"> <li> <!-- this craziness allows IE to lay subnavs on top of top nav elements if they break onto two lines --> <xsl:attribute name="style">z-index:<xsl:value-of select="count($nav)-position()+1" />;</xsl:attribute> <xsl:attribute name="class"> <xsl:if test="$currentPage/ancestor-or-self::*[@isDoc and name()!='Category2HomePage' and @id=current()/@id]"> <xsl:text>active</xsl:text> </xsl:if> <xsl:text> </xsl:text> <xsl:if test="count($nav)=position()"> <xsl:text>last</xsl:text> </xsl:if> </xsl:attribute> <xsl:call-template name="node-link-with-span"> <xsl:with-param name="node" select="current()" /> </xsl:call-template> <xsl:variable name="subnodes" select="* [@isDoc and string(umbracoNaviHide)!=1]" /> <xsl:if test="$subnodes"> <ul> <xsl:for-each select="$subnodes"> <li> <xsl:if test="position()=1"> <xsl:attribute name="class">first</xsl:attribute> </xsl:if> <xsl:call-template name="node-link-with-span"> <xsl:with-param name="node" select="current()" /> </xsl:call-template> </li> </xsl:for-each> </ul> </xsl:if> </li> </xsl:for-each> </ul> <xsl:if test="string($home/useAlternateNavigation) != '1'"> <img src="/static/phase2/tabNavBorderBottom.jpg" class="tabBorder" /> </xsl:if></xsl:template> <xsl:template name="node-link-with-span"> <xsl:param name="node" /> <xsl:if test="string($node) != ''"> <a> <xsl:attribute name="href"> <xsl:choose> <!--HERE IS THE PROBLEM TEST --> <xsl:when test="count($node/* [@isDoc and string(umbracoNaviHide) != '1'])"> <xsl:text>javascript://</xsl:text> </xsl:when> <xsl:when test="$node[name() = 'ExternalLink']"> <xsl:value-of select="$node/url" /> </xsl:when> <xsl:otherwise> <xsl:value-of select="umbraco.library:NiceUrl($node/@id)" /> </xsl:otherwise> </xsl:choose> </xsl:attribute> <span> <xsl:call-template name="node-name"> <xsl:with-param name="node" select="$node" /> </xsl:call-template> </span> </a> </xsl:if></xsl:template> <!-- A template to output the correct name for a given node. Better than copy/pasting this code all over the place --><xsl:template name="node-name"> <xsl:param name="node" /> <xsl:if test="string($node) != ''"> <xsl:choose> <xsl:when test="$node/pageTitle != ''"> <xsl:value-of select="$node/pageTitle"/> </xsl:when> <xsl:otherwise> <xsl:value-of select="$node/@nodeName"/> </xsl:otherwise> </xsl:choose> </xsl:if></xsl:template></xsl:stylesheet>
×