Jump to content

Aaron10

Members
  • Content count

    5
  • Joined

  • Last visited

Community Reputation

0 Neutral

About Aaron10

  • Rank
    Newbie
  1. Aaron10

    Text underlined in IE only

    I solved the problem. Silly mistake with a span tag.
  2. Aaron10

    Text underlined in IE only

    I have a webpage using a CSS for the text which works normally in all browsers including IE but it seems to be underlined in IE even though I dont have a text decoration of underline in the CSS at all, nor on the webpage. Is this a glitch with IE or is there some other behaviour I need to add to the CSS?
  3. The video seems to be working in Chrome without the data attribute but I'll stick it in there anyway.Thanks for the help.
  4. <object type="application/x-shockwave-flash" width="480" height="360"><param name="movie" value="flayr.swf?movie=stream.flv&color_background=ffffff&controls=true&color_buffer=#54019b&theme=skin.png&autoplay=false&buffer=true&preview=thumb.jpg" /><param name="allowfullscreen" value="true" /><param name="allowscriptaccess" value="always" /><img src="../images/noflash.jpg" width="480" height="360" border="0" alt="no flash" /></object> Awesome. But what do I put in the data="" field that you posted? It seems to work fine without it but if it needs to be in there do I put in my video file or flash player file?
  5. I have a video on my site which seems to work in all browsers but I'm trying to get it valid: <object width="480" height="360"><embed src="flayr.swf?movie=stream.flv&preview=thumb.jpg&name=&controls=show&color_buffer=#54019b&alpha_buffer=30&theme=skin.png" type="application/x-shockwave-flash" allowscriptaccess="always" allowfullscreen="true" width="480" height="360" /></object> The problem is of course coming from the embed tag. I've googled for ages trying to find the solution and have tried many ways but none seem to work. A total of 7 errors come from this: So yeah, everything within the embed tag pretty much.Here's the Player I'm using:http://www.flayr.net/After doing all settings and whatnot it gives you both an embed code and SWFObject code but with SWFObject the player fails to load at all in any browser, here's the SWFObject code anyway:<script type="text/javascript">var so = new SWFObject("flayr.swf?movie=stream.flv&preview=thumb.jpg&name=&controls=show&color_buffer=#ffffff&alpha_buffer=30&theme=skin.png", "flayr_player_id", "480", "360", "8");so.write("div_to_replace");</script> Thanks, hope someone can help.EDIT:I fixed it using the if IE tag. Anyone googling this, Internet Explorer needs this: classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" In the object tag, however other browsers will not show the object, so you need to use an if IE tag so that its compatible with all, heres the final code: <!--[if IE]><object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" width="480" height="360"><param name="movie" value="flayr.swf?movie=stream.flv&color_background=ffffff&controls=true&color_buffer=#54019b&theme=skin.png&autoplay=false&buffer=false&preview=thumb.jpg" /><param name="allowfullscreen" value="true" /><param name="wmode" value="opaque" /><param name="allowscriptaccess" value="always" /><![endif]--> <object width="480" height="360"><param name="movie" value="flayr.swf?movie=stream.flv&color_background=ffffff&controls=true&color_buffer=#54019b&theme=skin.png&autoplay=false&buffer=false&preview=thumb.jpg" /><param name="allowfullscreen" value="true" /><param name="wmode" value="opaque" /><param name="allowscriptaccess" value="always" /></object><!--[if IE]></object><![endif]--> And its valid.I've been searching for 3 days and I finally found the solution! Yay
×