Jump to content

rayj00

Members
  • Content count

    44
  • Joined

  • Last visited

Community Reputation

0 Neutral

About rayj00

  • Rank
    Newbie
  1. rayj00

    <i Tag Question used in Smarty

    Interesting. So where are these elements actually defined? How did JS know that the js_x-uploader meant to bring up a windows explorer window? Thanks, Ray
  2. Keep in mind I am not a web designer or PHP or Smarty developer. So, I have this smarty.tpl script that I am trying to figure out how the code flows. It uses smarty for creating templates. Within the file is an <i html tag. Researching it at https://www.w3schools.com/tags/tag_i.asp tells me it is used for styling text. However, I have the following: <i class="fa fa-video fa-fw js_x-uploader" data-handle="publisher" data-type="video"></i> {__("Add Video")} </span> My question is: It appears that the js_x-uploader affects what happens when I click on a link. The button is the "Add Video" button in a drop down menu. When I click the "Add Video" button a windows explorer pops and I pick a mp4 video to post to a page timeline. When I change the js_x-uploader to something else, arbitrarily, the win explorer does not pop. I am confused as to why js_x-uploader acts like this. There is nothing in w3school that explains this action for the <i tag? I hope I articulated my question enough? Thanks, Ray
  3. rayj00

    New At PHP....

    Interesting as I really can't see the board owner taking the initiative to include XML.
  4. rayj00

    New At PHP....

    I guess I wasn't clear. Who develops the XML or JSON code that is being used on the liberalforum or any othersite for that matter? I doubt that this particular site owner did it so that is why I asked if it comes with the software package?If I find a problem with XML or JSON being returned from the site, I need to know who is responsible, the site or the softwarevendor?Ray
  5. rayj00

    New At PHP....

    No I'm wondering why one query returns valid json and the other don't?Here's a dumb question: When you purchase something like a forum software (IP Board), does the XML come with it?Thanks,Ray
  6. rayj00

    New At PHP....

    I guess I am still somewhat confused. Why does one work and not the other?Ray
  7. rayj00

    New At PHP....

    Ok so as it stands now, using IE, if you browse to: http://novir.us/test.php?url=http://libera...l.php?showforumit returns valid json. At least it validates at JSONlint.comHowever, if I browse to http://novir.us/test.php?url=http://libera...hp?showforum=44(notice the only difference in the URL is the "=44")I get Warning: simplexml_load_file() [function.simplexml-load-file]: http://liberalforum.org/liberalforum/xml.p...wforum=44:2072: parser error : Input is not proper UTF-8, indicate encoding ! Bytes: 0x92 0x54 0x20 0x46 in /hermes/bosweb/web172/b1723/sl.novirusa/public_html/test.php on line 5Warning: simplexml_load_file() [function.simplexml-load-file]: <title><![CDATA[Hawaii Governor Can’T Find Obama’S Birth Certificate]]></###### in /hermes/bosweb/web172/b1723/sl.novirusa/public_html/test.php on line 5Warning: simplexml_load_file() [function.simplexml-load-file]: ^ in /hermes/bosweb/web172/b1723/sl.novirusa/public_html/test.php on line 5falseAnd you are saying this is a problem with liberalforum.org I believe? How would they fix this?Thanks,Ray
  8. rayj00

    New At PHP....

    Ok, so I'll stick with Firefox for now.So when i query http://liberalforum.org/liberalforum/xml.php?showtopic it looks fine on the browser as well as the ->View->Page Source.So the php script is (test.php):<?PHP$url = 'http://liberalforum.org/liberalforum/xml.php?showtopic';header('Content-Type: application/json');$xml = simplexml_load_file($url, 'SimpleXMLElement', LIBXML_NOCDATA);echo json_encode($xml);?> When I browse the script (http://novir.us/test.php) with Firefox, the only thing I get back is the request to open or save test.php?There is nothing in the browser, and nothing in the View->Page Source!
  9. rayj00

    New At PHP....

    Ok, there is a difference between IE and Firefox. In Firefox I query: http://liberalforum.org/liberalforum/xml.php?showtopic..and I get:<?xml version="1.0" encoding="UTF-8" ?><ipb> <categories> <category> <id>24</id> <name><![CDATA[Main Political Forums]]></name> <url><![CDATA[http://liberalforum.org/liberalforum/xml.php?showforum=24]]></url> <forums> <forum> <id>44</id> I cut off the rest to save size.Now in IE using the same query I get: The XML page cannot be displayed Cannot view XML input using XSL style sheet. Please correct the error and then click the Refresh button, or try again later. --------------------------------------------------------------------------------An invalid character was found in text content. Error processing resource 'http://liberalforum.org/liberalforum/xml.php?sho... <name><![CDATA[What President Obama This is getting weirder by the minute.
  10. rayj00

    New At PHP....

    I was away from this problem for a couple days. Now I am back to pulling my hair!!!here is the php:<?PHP$url = 'http://liberalforum.org/liberalforum/xml.php?showtopic';header('Content-Type: application/json');$xml = simplexml_load_file($url, 'SimpleXMLElement', LIBXML_NOCDATA);echo json_encode($xml);?> Here is the query: http://novir.us/test.phpHere is what I got back in the file save. I seen nothing in the browser.:<br /><b>Warning</b>: simplexml_load_file() [<a href='function.simplexml-load-file'>function.simplexml-load-file</a>]: http://liberalforum.org/liberalforum/xml.php?showtopic:48: parser error : Input is not proper UTF-8, indicate encoding !Bytes: 0x92 0x53 0x20 0x48 in <b>/hermes/bosweb/web172/b1723/sl.novirusa/public_html/test.php</b> on line <b>6</b><br /><br /><b>Warning</b>: simplexml_load_file() [<a href='function.simplexml-load-file'>function.simplexml-load-file</a>]: <name><![CDATA[What President Obama’S Heal...]]></name> in <b>/hermes/bosweb/web172/b1723/sl.novirusa/public_html/test.php</b> on line <b>6</b><br /><br /><b>Warning</b>: simplexml_load_file() [<a href='function.simplexml-load-file'>function.simplexml-load-file</a>]: ^ in <b>/hermes/bosweb/web172/b1723/sl.novirusa/public_html/test.php</b> on line <b>6</b><br />false
  11. rayj00

    New At PHP....

    You still with me justsomeguy?
  12. rayj00

    New At PHP....

    Here is the entire php script:<?PHP header('Content-Type: application/json'); //$url = 'http://liberalforum.org/liberalforum/xml.php?showtopic'; //$xml = simplexml_load_file($url, 'SimpleXMLElement', LIBXML_NOCDATA); $xml = simplexml_load_file(urldecode($_GET['url'])); echo json_encode($xml);?>
  13. rayj00

    New At PHP....

    I am using whatever my web provider is using. PHP version 5.2.12http://novir.us/phpinfo.php
  14. rayj00

    New At PHP....

    I use: echo json_encode($xml);
  15. rayj00

    New At PHP....

    Here is the error JSON:{"id":"40","name":""Liberals Only" Political Chat Room",Notice 2 sets of quotesRay
×