Jump to content

Search the Community

Showing results for tags 'call_user_func_array'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • W3Schools
    • General
    • Suggestions
    • Critiques
  • HTML Forums
    • HTML/XHTML
    • CSS
  • Browser Scripting
    • JavaScript
    • VBScript
  • Server Scripting
    • Web Servers
    • Version Control
    • SQL
    • ASP
    • PHP
    • .NET
    • ColdFusion
    • Java/JSP/J2EE
    • CGI
  • XML Forums
    • XML
    • XSLT/XSL-FO
    • Schema
    • Web Services
  • Multimedia
    • Multimedia
    • FLASH

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests


Languages

Found 1 result

  1. ckrudelux

    Arguments

    I just find my self thinking about how php reads arguments in a call, reason for this is what I just got stuck in call_user_func_array(). I'm calling the construct method in one class from this function with some arguments. The problem I face now is that I call the construct method 2 times which is not wanted. $params = array('arg1', 'arg2', 'arg3'); <?phpcall_user_func_array(array(new $_GET['class'], '__construct'), $params);?> This would be great if it worked like the one above but this just sends an array as argument. <?phpnew $_GET['class']($params);?> Any suggestions how to solve this?
×
×
  • Create New...