Jump to content

Search the Community

Showing results for tags 'troubleshooting'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • W3Schools
    • General
    • Suggestions
    • Critiques
  • HTML Forums
    • HTML/XHTML
    • CSS
  • Browser Scripting
    • JavaScript
    • VBScript
  • Server Scripting
    • Web Servers
    • Version Control
    • SQL
    • ASP
    • PHP
    • .NET
    • ColdFusion
    • Java/JSP/J2EE
    • CGI
  • XML Forums
    • XML
    • XSLT/XSL-FO
    • Schema
    • Web Services
  • Multimedia
    • Multimedia
    • FLASH

Calendars

  • Community Calendar

Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests


Languages

Found 4 results

  1. In-Tag Quotations???

    Hi there! I am in the process of coding a website and am working with HTML with an external CCS stylesheet. My issues are arising when I have things such as <img src="01.jpg" /> or <a href="page.html"></a>..... if I include the quotation marks within the tag (as exampled) the needed files do not get sourced, whereas when I leave out the quotes surrounding the item/file, (i.e. <img src=01.jpg />) they show up perfectly. I don't understand why this is happening and what I need to do to fix it?
  2. I'm pretty new to css but I've been working with it for the past few days, and this is the first real thing I can't quite figure out. Jsfiddle here. What I'm going for is to have .textone/.texttwo show and hide .text when hovering over one of the bottom two buttons. I've tried several things in order to get it to work, from deleting two div classes to leave the only class both the .text elements and .bottombutton as .box. I don't quite know what I'm doing wrong because I've seen other codes similar to this working but I just cannot get this one to function. The only thing I have had luck with is: .box:hover .text{display:none;} Which I would really rather not have to do since I do want the individual buttons to work. I guess the problem is with the relationship of two elements I'm trying to connect, since I have tried all of these: .buttonbottom:hover .text{display: none;} .buttonbottom:hover + .text{display: none;} .buttonbottom:hover ~ .text{display: none;} .buttonbottom:hover > .text{display: none;} None of which have worked. For good measure I also tested out the same idea with the .menu class by sorting it into a list but I've also had no luck there. Any help would be greatly appreciated! I do want to note that the code is for deviantart, which does have certain limitations (one of the biggest ones is that you can only define classes but not ID elements.)
  3. Troubleshooting help

    The comment basically has my issue, but I'm basically trying to fix my second var prompt so it will actually run and I can't figure it out. If anyone can help I would greatly appreciate it. Line comment: var one above this comment isn't working, how do I fix it? I also need it to continue to the next else if statement once something is entered. I'm thinking of making it so that if it changes var input to 2 once it's entered then 3, will that work? <!DOCTYPE html> <html> <head> <title>Project 1 – Michael Fiorello</title> <script> do{ var input = prompt ("Please enter 1, 2, 3, or exit.");{ if (input == "1") {for var one = prompt ("Please enter a string"); //var one above this comment isn't working, how do I fix it? I also need it to continue to the next else if statement once something is entered. I'm thinking of making it so that if it changes var input to 2 once it's entered then 3, will that work? if (one != null) else console.warn("You need to enter something") }in(one !="") //need the above "in" to cause it to loop this section until something is entered for var one else if (input == "2") { alert ("COOL!") } else if (input == "3") { alert ("AWESOME!") } else if (input.toLowerCase() == "exit") { alert ("Okay") } else { alert ("Nope") console.warn("You need to enter something"); } } }while(input != "exit"); </script> </head> <body> </body> </html>
  4. CSS problems with Firefox

    Hi, I know that this might be a quite common question but I haven't found a solution for my site so maybe you guys can help me out. I am not very experienced with this CSS stuff and I haven't been able to come up with a solution. My navigation bar works fine with other browsers but not firefox. You can find a live view of the site at: http://www.korukivi.fi/?page_id=375 Thanks for any help!
×