Jump to content

Search the Community

Showing results for tags 'vtt track video'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • W3Schools
    • General
    • Suggestions
    • Critiques
  • HTML Forums
    • HTML/XHTML
    • CSS
  • Browser Scripting
    • JavaScript
    • VBScript
  • Server Scripting
    • Web Servers
    • Version Control
    • SQL
    • ASP
    • PHP
    • .NET
    • ColdFusion
    • Java/JSP/J2EE
    • CGI
  • XML Forums
    • XML
    • XSLT/XSL-FO
    • Schema
    • Web Services
  • Multimedia
    • Multimedia
    • FLASH

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests


Languages

Found 1 result

  1. I have been struggling with video track for some time and can't get it to work. The video and audio work perfectly but not the subtitles. The CC button has no effect. I have configure IIS with the following line: <remove fileExtension=".vtt" /> <mimeMap fileExtension=".vtt" mimeType="text/vtt"/> I have tested this in the latest versions of FF, Chrome, Safari and Opera. This is the code: File: vtt_test.php<!DOCTYPE html><html lang="en"><head> <title>VTT Test</title> <meta charset="utf-8" /></head><body> <h1>VTT track test</h1> <h2></h2> <br><br> <h3></h3> <video width="640" height="480" controls> <source src="/movies/testbild.webm" type="video/webm" /> <source src="/movies/testbild.ogv" type="video/ogv" /> <source src="/movies/testbild.mp4" type="video/mp4" /> <track src="/tracks/video.vtt" kind="subtitles" srclang="en" label="English" /> <!-- fallback for rubbish browsers --></video> </body></html>File: /tracks/video.vttWEBVTT100:00:01.000 --> 00.00.02.900First line200:00:03.000 --> 00:00.05.900Second line300:00:06.000 --> 00:00.08.000Third line
×
×
  • Create New...