Jump to content
conradin

<CFQUERY datasource> question

Recommended Posts

Hi all, when I use the <CFQUERY name="getData" datasource="Data">the Data.mdb is assumed to be in the 1 directory up from the script that called it.(is that right? -- Thats what I think)anyways, Im working on a page that has the Data.mdb inside the web accessible directories. I want to change itso the data.mdb is not internet accessible. Can I specify another filepath for the local directory such as D:\Data or D:\Data.mdbAlternatively, should I use ../ notation to navigate to the data source?

Share this post


Link to post
Share on other sites
Hi all, when I use the <CFQUERY name="getData" datasource="Data">the Data.mdb is assumed to be in the 1 directory up from the script that called it.(is that right? -- Thats what I think)anyways, Im working on a page that has the Data.mdb inside the web accessible directories. I want to change itso the data.mdb is not internet accessible. Can I specify another filepath for the local directory such as D:\Data or D:\Data.mdbAlternatively, should I use ../ notation to navigate to the data source?
Your datasource needs to be defined in the ColdFusion Administrator. The tag attribute "datasource" doesn't work like other physical file attributes like "src" or "href". If you have access to the ColdFusion Administrator then login and goto your database settings and define your mdb there.Let me know if you have more questions.

Share this post


Link to post
Share on other sites

Ah, well it did work as described. There was some trouble. When I went to edit the datasource it simply refused to make the edit. The Database check returned ok, but then no one could log in, and ###### started breaking loose. Finaly, I deleted the old data source and wrote in a new one, and that worked fine. Thanks For the assistance! --Also, do I need to mark this thread as solved?

Your datasource needs to be defined in the ColdFusion Administrator. The tag attribute "datasource" doesn't work like other physical file attributes like "src" or "href". If you have access to the ColdFusion Administrator then login and goto your database settings and define your mdb there.Let me know if you have more questions.

Share this post


Link to post
Share on other sites

You can add [solved] to the title or subtitle, if you want.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...