Jump to content
Sign in to follow this  
Skemcin

PHP on 64bit

Recommended Posts

I have a VM Server I"m setting up for my test applications - Windows Server 2008 R2 64bit.I, simply, can't get PHP to work and I've followed a lot of processes: used installed, didn't use installer, used v5.3.x, used v5.2.x, used thread safe, used non-thread safe, used isapi, used fastcgi, and with all other other tweaks (application setting to make it run in 32bit mode) and I still end up with a 500 error.Here area a couple of links I referenced:http://www.codingday.com/php-installation-...-windows-vista/

http://www.iishacks.com/2011/02/14/how-to-...ows-2008-iis-7/http://www.lazynetworkadmin.com/knowledgeb...-server-2008-r2I've been taking snapshots of my server just before trying each one and I've been able to successfully load asp, aspx, htm, and even ColdFusion pages. Now, I understand int eh Default WebSite those are running in 64 bit and when I switch them to my 32 bit pool I expect them to crash (their engine is a 64 bit afterall) but then I expect PHP pages to load and they don't.Anyone else have this much problem with PHP on a 64 bit platform? Any advice?BTW, I need PHP because I am migrating two web sites to ColdFusion.

Share this post


Link to post
Share on other sites

What does the 500 error say? Most problems I've ever had were permission issues - you need to grant a specific username full access to your site folder, and then set this username as the username for your application pool. Also in the application pool, you should set "Load User Profile" to true (it's false by default). Without that, PHP just "pretends" to run with this username. The PHP folder needs to be (on the very least) readable by that username.For the actual installation... I've used this tutorial.

Share this post


Link to post
Share on other sites

I am suspecting it is a permission issue but I"ve run through all the options I can imagine or have found in the research I did.I've used both local and domain user accounts/groups and run into the same thing. I'll check out the tutorial you posted - thanks - and let you know what I get.What sucks is that I can't run the same site of 32bit PHP and 64bit ColdFusion - as it seems. It would be nice if I didn't have to associate the application pool with the web site or at least have it set to run off the default pool assigned to an application language (if you get what I mean).Ideally, I'd like to have asp, php, and coldfusion pages in one web site so I can migrate everything more seamlessly. The jury is still out on whether or not I can do that. I think I can - I should anyway, I'm not sure why the site cares when its the engine behind the request (php, asp, cfm) that needs to know.(I digress)I'll let you know if that tutorial helps.ThanksBTW : Have you used PHPManager for IIS?http://phpmanager.codeplex.com/

Share this post


Link to post
Share on other sites

No. I only saw it just now when trying to (re)discover the tutorial I was once using. Looks... fancy. I might start using it.

Share this post


Link to post
Share on other sites
No. I only saw it just now when trying to (re)discover the tutorial I was once using. Looks... fancy. I might start using it.
I tried it but since I"m not well versed in PHP I can't tell if it does a good job or not. I do know it's only for IIS7...ok so I was multi-tasking (writing and setting up) and it turns out that after I used the tutorial you referenced I (tried a few other things) and then used PHPManager for IIS and simply "registered" php with it and everything works now. I know what I did but it is a little bit of a blur because of how many times I did, undid, redid various things.I'll have to save this snapshot and try it again (for fun).Thanks for the reference, it definitely help (somehow).:)

Share this post


Link to post
Share on other sites

err, but only by server name (local and remote). When I access the site pages using the domains I entered in the host header I get the 500 Internal Server Error. But lets see if that is a caching issue that get resolved after I do a shut down, snapshot, and power up....

Share this post


Link to post
Share on other sites

That's why I usually test with "localhost" first - no (client) caching :) . Once you estabilish that, it's only a matter of setting the "bindings" properly.

Share this post


Link to post
Share on other sites

Yeah that's where I started too. An index file of each extension (php, asp, aspx, cfm, htm) with a functional tag of each respective language and opening in localhost all worked out. But then ... lol ... I think its working, I probably just have to close out of Firefox as it has proven to cache alot of DNS related stuff.(vm server is rebooting)

Share this post


Link to post
Share on other sites

Yeah, I've now memorized "ipconfig /flushdns" because of this AND have the command line pinned :) .

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...