Jump to content
Sign in to follow this  
hcccs

.vtt video track doesn't work

Recommended Posts

I have been struggling with video track for some time and can't get it to work. The video and audio work perfectly but not the subtitles. The CC button has no effect.

I have configure IIS with the following line:

      <remove  fileExtension=".vtt" />           <mimeMap fileExtension=".vtt"  mimeType="text/vtt"/>     

I have tested this in the latest versions of FF, Chrome, Safari and Opera. This is the code:

File: vtt_test.php<!DOCTYPE html><html lang="en"><head>	<title>VTT Test</title>	<meta charset="utf-8" /></head><body>	<h1>VTT track test</h1>	<h2></h2>	<br><br>	<h3></h3>	<video width="640" height="480" controls>  <source src="/movies/testbild.webm" type="video/webm" />  <source src="/movies/testbild.ogv"  type="video/ogv" />   <source src="/movies/testbild.mp4"  type="video/mp4" />  <track src="/tracks/video.vtt" kind="subtitles" srclang="en" label="English" />  <!-- fallback for rubbish browsers --></video>	</body></html>File: /tracks/video.vttWEBVTT100:00:01.000 --> 00.00.02.900First line200:00:03.000 --> 00:00.05.900Second line300:00:06.000 --> 00:00.08.000Third line

Share this post


Link to post
Share on other sites

The code looks OK to me. Have you checked the browser's developer tools to see that the file has loaded?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...