Jump to content
ShadowMage

Specified Driver Could Not Be Loaded

Recommended Posts

I'm not sure if this should go here or in PHP, but I'm having problems getting PHP to connect to a Progress DB.  I have IIS installed and configured on a Windows 2008 server and all seems to be fine on that front.  I can access the site, and I can run PHP code.  I can also access the MySQL databases we have.  When I try to access the Progress database, however, I get the following error:

 Warning: odbc_connect(): SQL error: Specified driver could not be loaded due to system error 5: Access is denied. (Progress OpenEdge 10.2A driver, \\share\path\to\file.dll)., SQL state IM003 in SQLConnect in C:\inetpub\phplib\ODBC.php on line 349

I created a system DSN on the webserver and I am able to successfully test connect from there.  I've also added full control for Everyone on the specified DLL (and the path to get to it) and still get the access denied error.

Any ideas or suggestions?

Thanks in advance for any help you can offer.

Share this post


Link to post
Share on other sites

I'm not sure how Windows permissions specifically work, but in addition to Everyone make sure that you have the IIS account also set up with permissions.  Maybe the IIS account specifically doesn't have read access and that overwrites the permissions for Everyone, but like I'm said I'm not sure specifically how it works in Windows.

Share this post


Link to post
Share on other sites

Maybe a silly question, but how and where do I find the IIS account?  I see a group called IIS_IUSRS but there's no members.

Share this post


Link to post
Share on other sites

Search for the account name for your version of Windows or IIS.  It used be called IUSR_ followed by the machine name.

Share this post


Link to post
Share on other sites

You did something like select IIS_IUSRS OR leave as is, and there should be a find button, by clicking that it would bring up a list, if i remember correctly.

Share this post


Link to post
Share on other sites

Seems like that was the problem.  Apparently Everyone doesn't include the IUSR...:huh:

I couldn't find a way to add the IUSR account to the share in AD, but I did figure out how to change the account used in anonymous authentication in IIS.

Share this post


Link to post
Share on other sites

We're migrating to Windows Server 2019 (IIS 10) now and this issue has reappeared.  I've changed the account in anonymous authentication to the domain admin account as before, but the error is still showing up.  I tried creating a new account specifically to run PHP/IIS and gave the account access to the share/file.  I tried specifying this account in anonymous authentication and in the application pool identity (and setting anon auth to use the app pool identity), but nothing seems to work.  Any ideas on what else I can try?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...