Jump to content
  • Announcements

    • boen_robot

      Guidelines and Netiquette   03/28/2017

      Posting Problems:   Having problems posting your topic? Read through this: To join, you agree to our terms and conditions and fill out and submit a registration form. An activation email will be sent to your email adress, so you'll need to verify your account. After that the account has to be validated by one of the moderators. This will mean that it can take up to a day to be activated. A couple of things to remember to ensure approval: Don't use an email address in one of those $2 four character .com domains eg. xyds.com. These will be deleted and the domain added to the banned list. Don't use an email address that is within a domain with a bad reputation for spam. A Google search is run on every email address and email domain. Don't sign up with an email address that doesn't exist, doesn't work or requires the sender to answer a quiz before their email can get to you. Put your country and or state and city in the signup form. Blank forms will go to the botton of the "to do" list. And make sure that your email address and your country match, saying you're from Alabama and using a .ru email address is not going to get you activated. After a membership is activated the first few posts will be monitored. Posting spam or unapproved topics described in the agreement results in an immediate ban. The email provider and the IP addresses associated with the account will be banned and all posts will be deleted. These strict measures have been deemed necessary to hinder spam. Sorry for any inconvenience this causes, but it's not liable to change. If, after reading this, you still can't post and don't understand why, contact one of the Moderators listed here.   Topic Guidelines   Including the following information can expedite an accurate response from board members: Must be a Specific Problem or Question related to web design and development Include Code in Question (wrap with   for small blocks of code and for longer blocks   ) Include Code Author Include Extra Notes/Modifications/Attempts Include web link to page/file when possible Content Guidelines   You may not post, upload, link to, or email any Content that contains, promotes, gives instruction about, or provides prohibited Content. Prohibited Content includes any Content that breaks any local, state, county, national or international law. Prohibited Content also includes: No direct or indirect advertising or websites, forums, products, services No hijacking of posts (do not post your question in someone elses) Content that infringes upon any rights [ex. MP3s and ROMs] (including, but not limited to, copyrights and trademarks) Abusive, threatening, defamatory, racist, or obscene Viruses or any other harmful computer software False Information or libel Spam, chain letters, or Pyramid schemes Gambling or Illicit drugs Terrorism Hacking or cheating for internet/online games Warez, Roms, CD-Keys, Cracks, Passwords, or Serial Numbers Pornography, nudity, or sexual material of any kind Excessive profanity Invasive of privacy or impersonation of any person/entity Hacking materials or information Posting Tips   There are more BBcodes than there are buttons for on the reply menu. To get the full list, click "BB Code Help" underneath the clickable smilie face menu. Use   for small snippets of code Use   for lengthy snippets of code Use   if your snippet is HTML (optional) Use   if your snippet is SQL (optional) Rules of Conduct   Be nice. There's no need for calling someone stupid if they ask an 'easy' question. Keep your avatars and signatures absolutely child friendly. We have a younger audience on this forum. Keep your language appropriate for the same reason above. Do not PM moderators for help on the forum. Post on the topic, or create a new one.   Spam:   Recently, as you have all without doubt noticed, we have had lots of spam and advertisement on the forum. Therefore, we'd like to alert you as to what to do when you have found any of the aforementioned annoying messages: it. Immediately. Give a clear reason, please, if the advertising is not evident. DO NOT POST! Report, let the post stay as is, and we will get to it, meanwhile if you continue to post as normal in the other threads, it won't be on the top so long. Refrain from PMing the member. This won't help at all, as they are most likely spambots anyway. Thank you.       Images in signatures:   After thinking of users on dial-up, we have decided to enforce the following rules regarding signatures. Please pay heed to them. Respecting these rules is respecting the members on this forum with dial-up. Signature rules: No animated images AT ALL. No matter the amount of animation. Maximum image widthxheight: 300x150 Maximum image (file) size: 15kb Use calm colors. Do not use highly contrasting images in your signature, as this can get really annoying when seeing several posts from one member in the same thread. The same prohibited content goes for images as for posts. Lastly, use common sense. No lengthy signatures please. Save us some scrolling. Thank you.       Links in signatures:   Please understand that w3schools.com only exists because of voluntary work and is barely supported by the advertising littered throughout the tutorials and the forum. So, please, stop advertising other sites. DO not post links that drive traffic away from the w3schools domain - especially to a site that offers similar if not identical information. Please help support the site by keeping individuals on it. Thank you. Here are some guidelines as to what you can put in your signature: w3schools links --> allowed w3.org links --> allowed browser links --> allowed html editor links --> allowed personal sites --> allowed tutorial sites competing with w3schools --> NOT allowed sites completely irrelevant to webprogramming and this forum --> NOT allowed   Thanks for understanding, and for taking the time to read this. ~W3Schools Modstaff~
Sign in to follow this  
mbpowner

geolocation null

Recommended Posts

justsomeguy    954

I don't see any content in your first post except a blocked request, but I assume that would return null if the user opted to not share their location.

Share this post


Link to post
Share on other sites
mbpowner    0

firstly i am getting this error 

"jQuery.Deferred exception: Can't find variable: google" "https://s.codepen.io/boomerang/iFrameKey-568d6cd1-874a-d6dd-bd79-55f4353f18e0/index.html?editors=1111:239:24

Share this post


Link to post
Share on other sites
mbpowner    0

also this error 

 

"Google Maps API warning: InvalidKey https://developers.google.com/maps/documentation/javascript/error-messages#invalid-key"

Share this post


Link to post
Share on other sites
mbpowner    0

but i havent used a callback function so i dont really know how to change that as i wish to leave it as it is where it loads as soon as the page is loaded..

Share this post


Link to post
Share on other sites
justsomeguy    954

I don't see those messages, I see lat and long are undefined.  That's probably because the callback won't get called if the user doesn't share their location.  You need to check if those variables are defined before trying to do something with them.  You can go that Google URL if you want to see information about the error message from them.

Share this post


Link to post
Share on other sites
mbpowner    0

Ahh I managed to see the issue was that, for some reason, you need to have a UserCoords object in order to be visible the latitude & longitude globally instead of setting long and lat variables, the variables will be undefined but using an object it works for some odd reason... 

Anyhow, managed to resolve hte null llocation issue. Other issue is the map won't load. If you click on the settings on the javascript you can see that this is my script src that i have used:

https://maps.googleapis.com/maps/api/js?v=3.exp&sensor=false

 

not sure why this isn't working... it used to work

i'm also not sure why my JSON data isn't working ?

Share this post


Link to post
Share on other sites
justsomeguy    954

I would guess that the map isn't loading because you don't have an API key.  At least, according to the URL in the error message.

Share this post


Link to post
Share on other sites
mbpowner    0

That's weird because it worked like this, just a few weeks ago. Could you tell me why the JSON data isnt loading please using that api ? 

Share this post


Link to post
Share on other sites
justsomeguy    954

If you're talking about openweathermap.org, my browser's console tells me it's because it's an insecure response.  That probably means the page was loaded over HTTPS but it's trying to send a request to HTTP and the browser is blocking it.

Share this post


Link to post
Share on other sites
mbpowner    0
9 hours ago, justsomeguy said:

If you're talking about openweathermap.org, my browser's console tells me it's because it's an insecure response.  That probably means the page was loaded over HTTPS but it's trying to send a request to HTTP and the browser is blocking it.

I figured it was to do with me using the wrong API key.  i kinda tried to use an open api key out there, but that failed. that must be something to do with secureness, i suppoe. something has changed lately. but anyways it worked when i created my own api key.

 

anyhow, still working on the google maps... they're just warnings regarding the api key, and was working fine before for sure. now i'm just not sure why it's showing a blue sky instead of land. also my location seems to be showing zagreb, when i'm actually in england. i think this is due to the inaccuracy of the api. i tried using the coordinates and they showed the right place with google... so the coordinates are right... but the sky is, for some reason, displayed on the map. whereas on the google maps website these coordinates display my universtiy

Edited by mbpowner

Share this post


Link to post
Share on other sites
mbpowner    0

By means of further experiment, I found that the api key does not matter. i tried entering the values of the coordinates directly for google maps to display. it works then.

 

however, it just seems to be an issue when using the objects UserCoords.lat and UserCoords.lng in the google.maps.latlng(UserCoords.lat,UserCoords.lng) object... what data types does the latlng take and how do i transfer it?

Share this post


Link to post
Share on other sites
mbpowner    0

sorry about this.. managed to resolve this too by putting it all in the method.. not sure why it wasn't accessible to the variables outside though

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×