Jump to content
Sign in to follow this  
LivingLearning

Apache Control panel not coming up via http://localhost approach

Recommended Posts

Hi all.  I'll try to be direct with the details.

I've installed a test server on my development pc (HP Envy, specs are fine) running win 8.1.

I used the 'xampp-win32-7.1.9-0-VC14-install' from the preferred site.

Installation went fine, no noted errors in any logs.

I changed the psswd for MySQL as suggested. (No prob there)

I can bring up the XAMPP control panel from command line fine (administrator priv) and I can start up Apache, MySQL just fine.  (logs all good)

(I'm not sure if I should be starting up the 'Tomcat' piece of the pie as well though, can't get a grip on what piece that plays in this picture.)

I won't be using the 'FileZilla' or 'Mercury' piece at the moment.

I can get into MySql and do stuff in there just fine via command line execution of the Control Panel (V3.2.2)

My problem is this.  I cannot figure out how to bring up Apache Control Panel via localhost.  This has eluded me for some time now.

I've read through dozens of posts from diff forums and still am not seeing the light on this issue.

Using FireFox or Chrome, when I type in "http://localhost/xampp" all i get is the default Dashboard. (like lots of other users have gotten, but I can't get an answer on this that I can understand.

I have all this installed under "c:/xampp and in the ~/htdocs folder I do have an index.php file.  I've moved that and still cannot get control panel to come up.

I'm thinking this might be a 'Path' issue, and there are not xampp files under that htdocs folder, since they shouldn't be there for public use i thought.

They are in a diff folder.  Perhaps that is just my problem.  I just need to tell it to look in a diff place. 

All the ports are default settings, not changed, and am not detecting any conflicts with any application port usage.

I'm just not sure on the proper use of this browser accessible approach still, lol.

Any suggestions.

Share this post


Link to post
Share on other sites

You shouldn't have to move or change anything, I'm sure that the Apache config files define a virtual directory (possibly /xampp) which points to a different location not inside htdocs.

If you're not looking for a default dashboard, what exactly are you looking for?

Share this post


Link to post
Share on other sites

hi try clicking on the xampp  icon to bring up your control panel the first field is apache click adman that brings up your dashboard.what you need to do is make a folder in your htdocs folder  you can name it what ever you want then type in your browser http://127.0.0.1/your folder name click  enter  that should bring up your index .hope that helps. dont  think cpannel is intended to be openly shown publicly

Edited by codeminer

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×