Jump to content
Heinz57

strange html decoding?

Recommended Posts

This may be slightly off topic but where should I go?

I am helping a blind fellow to use JAWS for Windows. When reading some emails we often get this strange translation of HTML when and apostrophe is intended:

Much of this sites popularity comes from its active user community

 

The corresponding HTML is:

Much of this site</span><span style='font-size:12.0pt;font-family:"Tahoma",sans-serif;color:#606060'></span><span style='font-size:12.0pt;font-family:"Arial",sans-serif;color:#606060'>s popularity comes from its active user community

What can be done to fix this? Do I need to change a setting?

Thanks,

Heinz

Share this post


Link to post
Share on other sites

This usually happens when the page or content produced is not UTF-8 encoded, have you set the charset?

https://www.w3schools.com/tags/att_meta_charset.asp

All these documents should be saved and produced using UTF-8 encoding, most web based editor do this automatically, notepad need to be specifically saved and mac text editor setting need changing to be used as html editor as UTF-8 encoded.

If database driven, it should be set to use UTF-8 encoding by database and tables.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×