Jump to content
141080

Using SVG Flags Plugin, but does not show inline anymore

Recommended Posts

Hi, on my website 141080. com I use a plugin called "SVG Flags". 

All of a sudden, the flags were not displayed inline anymore. It does not look nice. 
The support said, I should "just" use some css code to display the flags inline again. 

For example: there should be the flag of Germany and the word "Deutschland" right behind it, not in the next row.

When you got to my website, you can find the flags in the sidebar.

Thanks for your help :)

Dennis

Screenshot 2020-01-09 at 22.19.14.png

Share this post


Link to post
Share on other sites

The flags are wrapped in <div> tags, so they're blocks and force adjacent content to the next line.

It's easy to fix. All of these divs have a class "svg-flag", so you can just display them as inline blocks. You can add vertical-align to better align them with the text.

.svg-flag {
  display: inline-block;
  vertical-align: middle;
}

 

  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...