Jump to content

rmpotter

Members
  • Content Count

    40
  • Joined

  • Last visited

Everything posted by rmpotter

  1. this looks perfect. Thank you for your input
  2. I am looking for some input for a simple site I have been asked to make.Basically, I am looking for a decent way to allow a user to edit the news text in one DIV on a site driven by PHP. I am not familiar with how this is usually done, should I just use a simple text box or is there something more elaborate someone could point me too?
  3. thanks, i'll give it a try
  4. I am looking for a simple way to save a date to MYSQL and then later extract it and add 60 days on to it. I am unsure the best format to save the date as for later extraction, currently I am using SQLs curdate() but feel using PHPs Date() may be easier to add time. Any ideas?
  5. Alright, so I replaced what I wrote, with what you wrote.. and the only difference between yours and mine was that yours outputted the session uid, which I actually have tried, to confirm what the uid was, and it outputted programmer every time. But regardless, I copied yours in, and I edited yours to be like this: /* if ($_SESSION['uid']!='programmer') { header('Location: index.php'); exit; }*/ if ($_SESSION['uid']!='programmer') { if(isset($_SESSION['uid'])) { echo $_SESSION['uid']; } header('Location: index.php');
  6. Alright, so I have this code: <? if ($_SESSION['uid']!='programmer'){ header('Location: index.php');exit; } include_once ("header.php"); ?> even when the uid is 'programmer' it redirects me to index... I obviously don't want this to happen.. if the user ligged in successfully as programmer, I want him to go to the correct page. Can anyone please tell me why this is happening?URL - http://nait.jtlnet.com/~fpkj5v0r/index.phpUser: programmerPass: prog123After you login, you can see that the uid is programmer, because I output it to the screen (it's on the banner, beside Logou
  7. ooohhh man, classic case of not clearing my cache.. I'll never learn!Thanks everybody I truly appreciate the help! I love how forums work, and I love the people that work on them!
  8. Oh, I forgot to mention, the response is empty for the link that calls the ajax... In fact, I will give you the URL for the site.Keep in mind, this is a dumbed down site, so I can practice little things on... and these little things are now giving me a headache.http://nait.jtlnet.com/~fpkj5v0r/programmer.phpgo to the guestbook, and read guestbookif you write in the guestbook, it does get entered, so that is good.
  9. I don't seem to be getting any javascript errors.The firebug tells me the headers contain: text/plain.I'm not sure where to check the responseText property though.
  10. So I changed the x variable to global, and it still didn't work :)Also, yes, I do end the div. I thought this was gonna be easy. I just want to view a text file in the damn div. The content of the text file is enclosed with the <pre></pre> tag.
  11. Hello. I'm doing something very simple, and yet it's not working.. maybe I'm missing something.I need to read a text file, through ajax, and into a div. I can easily write to the file through ajax, but not read. Here is what I have: function ajaxLoader(url){if(document.getElementById){var x = (window.ActiveXObject) ? new ActiveXObject("Microsoft.XMLHTTP") : newXMLHttpRequest();}if(x) {x.onreadystatechange = function() {if(x.readyState == 4 && x.status == 200) { el = document.getElementById('content'); el.innerHTML = x.responseText; } }x.open("GET",url, true);x.send
  12. I am having trouble trying to figure out how to update my sidebar using ajax.Right now I have an open button on my sidebar that loads up some php in another div. The SQL selected in this div is supposed to the propagate back to the div containing the sidebar.Any ideas?
  13. Unfortunately, that's what I figured. I will fool around with it an post a solution for anyone interested.
  14. Currently I am attempting to pull some data using:$sql="select * from inspect_erp where inspection_id = ".$myid." ORDER BY erp_type";the fields in the table areerp_id, inspection_id, erp_type, gpslocationBasically, I am looking to alter this to have the SQL order by the most commonly occurring erp_type to the least occuring. Can anyone help me out?
  15. sorry, wrong url. Here it is:http://www.charmscorp.com/inspect/projects.php
  16. okay, so if you go to the website that I've been working on: http://beta.charmscorp.com/inspect/projects.phpin firefox, the site looks how it's supposed to (don't mind the slow load up time, it's a server issue). You will have to wait a few seconds for the content to fully load. If you rollover the tabs, it all works finein IE8, the site is messed up, the tabs at in the center/right of the page, and if I take a certain css line out (position: absolute;), then the tabs are put back there they belong. I need to use position of absolute though because of the dynamic tabs that have collapsible par
  17. I didn't know if I would put this problem under the html section instead, but I suspect this to be a css problem.. let me know if I'm wrong.anyways... the problem is this: My tabs are pushing down the content below it. Here is some of the code: <div id="navigation"> <div id="test" class="blue"> <p><a href="<? echo $web_app_path ?>home.php">Home</a></p><p class="subtext">View/update contact information</p> </div> <div id="lessons" class="blue"> <p><a href="<? echo $web_app_path ?>projects.php">Projects</a>
  18. unfortunately the fast CGI settings did not help
  19. Alright, well thanks for all of your help. We'll try what you said, keep trouble shooting, and worst case scenario, we get someone to come in and look at the server. When we find out the cause and the fix, I'll post here to let you know what it was. Thanks again!
  20. alright, so the error logging works. I just tried it and it found an error that I purposely gave it. But it finds no errors otherwise...
  21. ya, I tried that earlier, I put: error_log = F:\PHP\errorlog.txt, and nothing is written. Hmmm.Were you able to peek at the php.ini file? I've been going over it for the past little bit here, but not being a php/mysql guy, I'm not sure at some of the things I'm looking at. I turned off buffering, thinking that might be it, but no go.I may have to get a PHP pro in here, just to reconfigure the ini file and/or troubleshoot this problem, because it's quite crippling, especially when it's in a file I never created
  22. Alright, so I did this:; Log errors to specified file.error_log = errorlog.txt; Even when display_errors is on, errors that occur during PHP's startup; sequence are not displayed. It's strongly recommended to keep; display_startup_errors off, except for when debugging.display_startup_errors = Onerror_reporting = E_ALLNo errorlog.txt file is ever created though, even after loading up various ajax/php. Would this mean no error are being generated?
  23. I just checked in the php.ini file, and I see various logging settings turned off. Mainly these 2: ; Log errors to specified file.;error_log = filename; Log errors to syslog (Event Log on NT, not valid in Windows 95).;error_log = syslogIf these are the error logging settings you were talking about, I'll uncomment them immediately.
  24. I will check to see if error logging is enabled in the php.ini file (this file is relatively new to me), and whatever the case, I'll look into these logs.The php.ini file is: http://rapidshare.com/files/280491999/php.ini.html I appreciate all of this help!
  25. Yes, sorry, I noticed right away that I needed to add the timer to the actual script, my bad. Now, I added that timer, and edited the code to time the php, and it was fast. if you go to the site again... http://beta.charmscorp.com/inspect/projects.php and open project, and pick one, and then hit open, and wait, it will show you the time... it was .0068 seconds for me, which is nice and fast. It once again took forever to post though. Not sure what to do from here.I also disabled the extensions one by one.. and when I disabled a crucial one, the site ceased to function, so it is using the ini f
×
×
  • Create New...