Jump to content

Created a flash movie and I think I need a "loading" frame


pafruu

Recommended Posts

Hi all,just created a movie in flash with a couple of flv files and an mp3. When testing the movie from flash itself, everything jives and is on cue but when its brought on to html.... its a whole different story. Somehow the movies and the graphics seem to be slower than they are supposed to be, the music does not jive at all..My question is this. Would a preloading frame, indicating the user that the movie is loading, be the solution?If so what is the code, I unfortunately am getting old and forgetting simple stuff! :) Thanks!

Link to post
Share on other sites

did you make the preloader correctly?Its quite easy to make one...but quite easy to make it not work!(check for topics on here to find how to make one! Or google it!)Smiles has got the right idea!Flash 8 help is a good tool sometimes!!

Link to post
Share on other sites

ok I found a code on a discussion:stop();totalbytes = getTotalBytes();loadedbytes = getLoadedBytes();totalkbytes = Math.ceil(totalbytes/1000);loadedkbytes = Math.ceil(loadedbytes/1000);percent.text = Math.ceil(totalbytes/loadedbytes*100)+"%";totalk.text = totalkbytes+"kb";loadedk.text = loadedkbytes+"kb";if (loadedbytes == totalbytes) {_root.gotoAndPlay(2)};I,ve put it in the first frame of my movie, which starts on the second frame, somehow its still doesn't work when I look at it through my HTML page??I've got dynamic text called "percent" width of 100 and totalk and loadedk, on the same frame

Link to post
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...