Jump to content
gilgalbiblewheel

child movie clip not resetting color from parent movie

Recommended Posts

I'm trying to reset the color of the child movie clip by ActionScript of the _parent or _root movie clip. It's not working:http://n.1asphost.com/wheelofgod/flash/genesis.html

on(rollOver){	colorobject = new Color([b]this.left_container.left_empty.iicor11_h[/b]); [color="#9ACD32"]//creates a new color object from a color class	colorobject.setRGB(0xFF9900); //color colorobject in green (0x 009900 indicates HEX)[/color]}on(rollOut){	colorobject = new Color(this.left_container.left_empty.iicor11_h); [color="#9ACD32"]//creates a new color object from a color class	colorobject.setRGB(0xFF0000); //color colorobject in green (0x 009900 indicates HEX)[/color]}on(release){	gen27b_h._alpha = 75; [color="#9ACD32"]//dan4_h stands for the highlighted words[/color]	_root.right_container.right_empty.loadMovie("gen_clips/sp3/2cor11.swf");}

this.left_container.left_empty.iicor11_h left_container is the instance name of the _root, left_empty is the instance name of the first child movieclip, iicor11_h is the instance name of the third. The third movieclip is a separate exported file.Would you know what causes the problem that it wouldn't work?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...