Jump to content
SmokingMan

:hover working on some links but not all

Recommended Posts

I have some links where the ":hover" doesn't work. It works with the links at the top of the page, but not with the links that return to the top of the page. All of these links are within the page. Here's the page: store menu.And here's the CSS: stylesheet.The only problem is with the "return to top" links. They display fine, they just don't change on hover. :)

Share this post


Link to post
Share on other sites

Your selector is off a bit. It is currently:

.menu-return a:hover{  font-weight: bold;  text-decoration:underline;}

Which would apply the style on hover of any anchor inside of an element with the class of "menu-return". The links on your page, however are using "menu-return" as the class. I believe your selector should look like this:

.menu-return:hover{  font-weight: bold;  text-decoration:underline;}

Share this post


Link to post
Share on other sites

btw, you're missing a closing </a> tag on line 315:

<td colspan= "3"><a class= "menu-return" href= "#menu-links">Return to top</td>

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...