Jump to content
oneoleguy

$_POST

Recommended Posts

Does anyone know where the default passwords are with this installation of Apache?I've looked, but without success.One Ole Guy
What are you talking about? Apache has no passwords by default. Only MySQL does, and it asks you to set them when you install it. In the case of premade packages, look at the site of the package for this information.But again, Apache has no passwords.

Share this post


Link to post
Share on other sites

boen_robot,ftp requires a username and password, phpmyadmin requires a username and password, phppfstd requires a Login (what ever that is), phpxmail requires a username and password, uebimiau.webmail require a username and password.There are probably other areas of the Apache2Triad installation that I haven't explored yet that need username and password. Some, like the phpxmail may require me to set up accounts and I don't know how to do that.I know that MySql is part of the installation and haven't figured out where the Admin and/or tutorial areas are. It's a huge package. The installation excecutable was 98 MegaBites BIG. The installation program was looking for at least 248 MB of free storage space to install the software in. There's more than Apache here.So I do need a little assistance.Thanks,One Old Guy

Share this post


Link to post
Share on other sites

During the installer it asked your for the root password you would like to use. Whatever password you chose there is the password for apache2triad.

Share this post


Link to post
Share on other sites

I used that password to get into the ftp administrator: phpsftpd. Now all I need to know is how to use it!Anyway, the issue with the PHP files is resolved... It's my hosts issue.Further discussion of Apache should be done elsewhere.I thank each of you for helping me find the answers I needed.Have a nice day,One Ole Guy

Share this post


Link to post
Share on other sites

First: One Ole Guy: I admire your tenacity, you look like you're searching for answers.Second: People, what are you doing? Registering globals is never the answer. To anything. Ever.Let's start over. The original problem was that you had some undefined indices:

Notice: Undefined index: radio in /home/vh1176/www/billsplace.us/fg/process2.php on line 173Notice: Undefined index: active in /home/vh1176/www/billsplace.us/fg/process2.php on line 174Notice: Undefined index: select in /home/vh1176/www/billsplace.us/fg/process2.php on line 175
PHP is saying that the indices "radio", "active", and "select" were not found in the array (in this case $_POST). All that means is that the HTML form that submitted to the PHP script did not have form elements called "radio", "active", and "select". So, we need to look at your form to figure out why those elements aren't being submitted. The basic answer is because they aren't in the form, if they were in the form then they would be submitted. So, let's check the form. You have elements like this:<input type=text name='select[$i][$j]' size='20'><input type=hidden name='active[$i]' value='...'><input type=text name='radio[$i][$j]' size='20'>That stuff looks like it should work (it should be building arrays for PHP called 'select', 'active', and 'radio'), but it's not. It might be that those elements are never being written or it might be that PHP is confused with the naming. When all else fails, check the HTML. Pull up your HTML form in a browser, go up to View->Source, find the HTML code that the PHP generated, and paste that HTML code in here so we can see the actual HTML form that the PHP page is building.

Share this post


Link to post
Share on other sites
Second: People, what are you doing? Registering globals is never the answer. To anything. Ever.
All I was saying was that maybe the PHP application originally was designed for register_globals to be on.
This feature is DEPRECATED and REMOVED as of PHP 6.0.0. Relying on this feature is highly discouraged.
It is true that register_globals is a very insecure feature, but it is still around in PHP 5 and some developers still use it.

Share this post


Link to post
Share on other sites
All I was saying was that maybe the PHP application originally was designed for register_globals to be on.
Then you redesign the application to not rely on register_globals, that's the solution. The solution isn't to enable register_globals. Any decent PHP developer does not write applications that rely on register_globals being enabled, it's just sloppy to do so.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...