Jump to content

some problems


Recommended Posts

hi.i have some problems with embedding multimedia in my web page. i have windows media player 11 as my default player.I also have jetAudio,winamp,realplayer and quicktime.the line below works well in internet explorer 6 but when i try it in firefox 1.5,Opera 9 and netscape 8 the browser prompts that a plugin is needed to play the file.why they can't use windows media player to play the file.Can i fix the problem or i have to download the plugin?

<embed src="Multimedia/sth.avi" type="video/x-msvideo" width="200" height="150">

---------------------------------------------------------------------------------------------------------------------------------------------------the line below doesn't show anything in firefox 1.5, Opera 9 and netscape 8 and when i try it in IE it opens the windows media player instead of showing the file in the browser.

<object data="Multimedia/sth.avi" type="video/x-msvideo"></object>

---------------------------------------------------------------------------------------------------------------------------------------------------

<object classid="clsid:22D6F312-B0F6-11D0-94AB-0080C74C7E95"><param name="FileName" value="sth.avi" /></object>

works well in IE but it has no effect on firefox 1.5, Opera 9 and netscape 8.i tried other file extensions but they have the same problem as well.do i have to download the plugins for each browser or there is another way to make the things all right?what do i need to play flv files in the browser?Can i embedd them using the code i have written above or they need some code like flash or real?thanks.

Link to post
Share on other sites
Guest FirefoxRocks

In Firefox/Flock, try clicking on Install Missing Plugins to see which plugin it is trying to install. In Windows, I have Windows Media Player and it is shown as an embedded object in Firefox whenever I watch WMV movies. Opera does the same thing also, and Internet Explorer works. I don't know which code the sites are using, but I suppose you can try this:

<object data="Multimedia/sth.avi" type="video/x-msvideo"><object classid="clsid:22D6F312-B0F6-11D0-94AB-0080C74C7E95"><param name="movie" value="sth.avi" /></object></object>

I thought that AVI was handled by QuickTime.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...