Jump to content

inserting chinese character in notepad


matrixtlm
 Share

Recommended Posts

One quick question. My page contain Chinese character. How do I display it, since i'm using notepad to design. If i paste the chinese character directly to the notepad, inside the notepad will appear as some funny characters/square boxes. But it does display the right character in the browser. But it will be rediculous to script the notepad with squareboxes everywhere. Would like to know whether is there a more proper way to display chinese character in browser.I remember i come across some encoding. Example "#82342" represent one chinese character. So all the chinese character is actually being represent with codes like "#45345". But i can't find any further info on that.Can anyone advise a little.Thanks.

Link to comment
Share on other sites

Get a more usefull editor. Most (all?) of them automatically convert the character into it's entity when it's typed/pasted into their design(NOT CODE!) box.One more thing... entities begin with &. For example   returns space. The same way, a number equivalent would return that character.

Link to comment
Share on other sites

I use Korean, which has the same issues as Chinese. You can usually install an IME for the language you want to use - in your case Chinese. This is true for windows and linux. The IME gives you a way to input that language. Just search the internet for Chinese IME.If you are on WinXP, just go to the control panel and select "Regional and Language Settings". Select the "Languages" tab. Click on "Details". You should see a section called "Installed Services" with English listed. Click the "Add" button. Choose your Input Language and IME.There may be a checkbox on the "Languages" tab that says something about installing files for East Asian Languages... I think this might include Chinese... but I'm not sure...I use notepad very often on an English version of WinXP and have no problems entering Korean text. You should be sure to define the encoding of the page using meta tags:

<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />

I prefer using utf-8 because I use a mix of languages. Make sure that you actually save the files in the same charset that you specifiy in the meta tag - in notepad choose "Save As..." and choose UTF-8 as your encoding.Hope this was atleast a little helpful.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...