Jump to content

simplesli.de plugin help


cinek
 Share

Recommended Posts

I'm trying to use the simpleslide plugin, but it doesn't seem to work. 1 it doesn't move to the next image at all. It also is not displaying the next & previous arrows. I have no idea what's wronghere's my htmlbtw the a.js file contains the plugin code

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd"><html xmlns="http://www.w3.org/1999/xhtml"><head><meta http-equiv="Content-Type" content="text/html; charset=utf-8" /><title>Untitled Document</title><script type="text/javascript" src="https://ajax.googleapis.com/ajax/libs/jquery/1.4.4/jquery.min.js"></script><script type="text/javascript" src="a.js"></script><script type="text/javascript">$(document).ready( function(){ simpleSlide(); });</script></head><body><h1>Gallery 1</h1><div class="simpleSlide-window" rel="1">	<div class="simpleSlide-tray" rel="1">		<div class="simpleSlide-slide" rel="1" alt="1">			<img src="someimage">		</div>		<div class="simpleSlide-slide" rel="1" alt="2">			<img src="someimage">		</div>		<div class="simpleSlide-slide" rel="1" alt="3">			<img src="someimage">		</div>	</div></div> </body></html>

I've added the arrow divs, but it still doesn't work.

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd"><html xmlns="http://www.w3.org/1999/xhtml"><head><meta http-equiv="Content-Type" content="text/html; charset=utf-8" /><title>Untitled Document</title><script type="text/javascript" src="https://ajax.googleapis.com/ajax/libs/jquery/1.4.4/jquery.min.js"></script><script type="text/javascript" src="a.js"></script><script type="text/javascript">$(document).ready( function(){ simpleSlide(); });</script><style>body { background: black; }.simpleSlide-window { margin: auto; }.left-button {background:url(../garski.net/dodatki/michal/poprzedni-1.png) no-repeat; }.right-button { background:url(../garski.net/dodatki/michal/nastepny-1.png) no-repeat; }</style></head><body><h1>Gallery 1</h1><div class="left-button" rel="group">	</div><div class="simpleSlide-window" rel="1">	<div class="simpleSlide-tray" rel="1">		 		<div class="simpleSlide-slide" rel="1" alt="1">			<img src="1.jpg">		</div>		<div class="simpleSlide-slide" rel="1" alt="2">			<img src="2.jpg">		</div>		<div class="simpleSlide-slide" rel="1" alt="3">			<img src="0.jpg">		</div>	</div>      </div> <div class="right-button" rel="group"></div></body></html>

if I put images in the divs, it doesn't help either, the images are not clickable at all

Edited by cinek
Link to comment
Share on other sites

this is what I get:(all warnings)

[20:27:39.743] Unknown pseudo-class or pseudo-element 'hidden'. @ file:///C:/Users/cinek/Desktop/a/index.html[20:27:39.609] GET https://ajax.googleapis.com/ajax/libs/jquer...4/jquery.min.js [HTTP/1.1 304 Not Modified 51ms][20:27:39.684] Unexpected token in attribute selector: '!'. @ file:///C:/Users/cinek/Desktop/a/index.html[20:27:39.733] Unknown pseudo-class or pseudo-element 'hidden'. @ file:///C:/Users/cinek/Desktop/a/index.html[20:27:39.739] Unknown pseudo-class or pseudo-element 'hidden'. @ file:///C:/Users/cinek/Desktop/a/index.html
firebug isn't showing any errors Edited by cinek
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...