Jump to content

anchor in firefox


joecool2005
 Share

Recommended Posts

which version of FF? what happens instead? It works for FF4. Maybe you have special settings set in the browser for dealing with https based URL's?

Link to comment
Share on other sites

You mean the # part isn't working, right?it seems to be working, although I can't vouch for the behavior in IE. You can tell its scrolled down a bit because the veritcal scrollbar isn't positioned all the way at the top. You can try this to see another case where it's "working."https://secure.drtax.ca/ufile/2010/help/hlp_tslip.htm#RL10

Link to comment
Share on other sites

Hi,Why this anchor works in Internet Explorer but not in Firefox?https://secure.drtax.ca/ufile/2010/help/hlp_tslip.htm#T4RSPThxJoe
validate your code. I have also run into this problem.Your anchor "T4RSP" is not properly nested. Some browsers ignore this limitation while others just crash on it. In the case of Chrome it just advances to the beginning of the table which is where the anchor would be valid.same happens when I try to access RL10, I just get to the beginning of the table in which the anchor is located.There must be a rule somewhere I have not yet found that specifies where you can place an anchor in a table. If I remember correctly, placing the anchor inside the <TD> element will work but the browser will top the window a half-line too low....don't quote me on this...experiment................Guy
Link to comment
Share on other sites

Ok I found my error. In my code I had this

 <tr><a name="T4RSP"></a>	<td><b>T4RSP</b> - RRSP Income</td>	<td> <a href="java script:void(0);" onclick="searchTOC('Q2PENS*', 'G92E8');"><IMG src='../pic/fix.gif' border='0' title='Let's go'>	  Pension income and T4A</a></td>	<td>Tick <i>Income from pension or T4A </i> in the <a href="java script:void(0);" onclick="searchTOC('PREINT*', '');">Interview	  setup</a>. </td>  </tr>

it should be this

 <tr> 	<td><a name="T4RSP"></a><b>T4RSP</b> - RRSP Income</td>	<td> <a href="java script:void(0);" onclick="searchTOC('Q2PENS*', 'G92E8');"><IMG src='../pic/fix.gif' border='0' title='Let's go'>	  Pension income and T4A</a></td>	<td>Tick <i>Income from pension or T4A </i> in the <a href="java script:void(0);" onclick="searchTOC('PREINT*', '');">Interview	  setup</a>. </td>  </tr>

<a name="T4RSP"></a> was in the wrong place. Sounds like FF is more sensitive. Now it's workingThanks for you helpJoe

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...