Jump to content

Recommended Posts

I still haven't been able to get this to work. I get an error on line 37 in the code. can some one please help me fix this. I get an error of null is null or not an object. on line 37. Here is the home page http://nicedit.com/download.php and the owner took his forums off line and when I emailed him, He wanted me to pay him. Wel I attached to this post. Please any one. Joe

nicEdit-.zip

Link to post
Share on other sites

Click on which thing of the lower left corner? Just upon loading the page Firebug gives me two errors:"B is null" in nicEdit.js"NetworkError: 404 Not Found - http://toppersbbs.dtdns.net/mapnet/style/templates/footer.css" If I click on "edit profile" I get this:

Notice: Undefined index: userid in C:\www\vhosts\_static\webroot\mapnet\profile.php on line 119
  • MySQL: "fatal error: error in query: 'SELECT * FROM cms_profiles WHERE uid=':You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '' at line 1"

But that doesn't have anything to do with Javascript.
Link to post
Share on other sites

Ok, The reason why your getting the other errors is becuase your not log in, Ok. That's why your getting the userid error and so on. I still haven't added all the security in yet. The problem I'm having is that when I add the links for the micedit.js file to my header.html. That's when I get that error.

Link to post
Share on other sites
Where are the textareas that you're trying to convert? It looks like your code is trying to add 5 nicEditors, but I can't find the textareas that you're telling it to convert.
That's because I haven't added them in yet. and well I need to get this error in the javascript fixed. I'm not sure in nicedit will work right.
Link to post
Share on other sites

nicEdit is probably throwing an error because it can't find the element it's looking for. You really should fix your HTML, it's a mess and it might mess with your CSS and Javascript.

Link to post
Share on other sites
That's because I haven't added them in yet.
Don't you think that might be the problem? You're telling it to convert "area1", you get an error that it expects an object where there's not one, and you don't think to add the element that you're telling it to convert? The error happens because you are telling it to convert 5 elements that do not exist.
Link to post
Share on other sites

Nope. Due to the fact that I all ready added it and I still get the same error. I had to comment out the javascript code just to get the error to stop in IE. the other problem that I have is folders and the php files. and so I know I'll have to post on that too. any way. I took the security off. go to http://toppersbbs.dtdns.net/mapnet/blog.php and look at the page, then goto click the link that says add entry,just under the 1st blog. and look at the page again. See this is the crap I have to deal with and most of the time I don't know what I'm doing. So I'll have to start another post about this. any way I see the header is being loaded and that the textarea should have the new text box showing and well as you can see that doesn't work. I have it set to area2 in the javascript and well ?. I don't know what to do...

Link to post
Share on other sites
Nope. Due to the fact that I all ready added it and I still get the same error.
I guarantee that the error message I saw was because you were trying to convert 5 elements that were not present. I don't know if the changes you made are correct or if you're seeing a different error that you think is the same. I get fatal errors on the link you posted, there's nothing to click on. It looks like it can't find files that it's trying to include.
See this is the crap I have to deal with and most of the time I don't know what I'm doing.
That's definitely part of the problem, but we're here to help teach people. The first step in debugging problems like this is to pay attention to the error messages, and trust that they are correct. If it tells you there is an object missing, then you're telling it to access an object that isn't there. If it still tells you the same thing, then it's still trying to access an object that isn't there. To blithely assume that's not true, that the browser is lying, because you tried something that you thought was correct, isn't helping yourself. The browser is not lying. Your code is still wrong. You admit that you don't know what you're doing, so don't assume that the browser is wrong. You should be asking questions like why whatever you tried didn't work, but in order to answer those questions we need to look at your code. One of the most important skills a programmer can have is to be able to debug problems. The most important part of that is to look for and trust error messages. There are several people here answering questions which you don't see asking questions of their own, and the reason they don't ask questions is not because they never have problems, it's because they understand how to start at an error message and find the problem.
Link to post
Share on other sites
Well like you told me how to fic the click.js file and your idea did work. Ok so lets see if we can fix the micedit problem. Ok, I removed the security from the pages. If the web site was up and running, you wouldn't be getting all of thise errors. Because you wouldn't have access to some or all of the pages. Ok. You MUST BE LOG IN. Most of those pages require $_SESSIONS and these's sessions that are missing are where the errors are coming from. Ok. It's not coming for the pages. It's coming from the PHP sessions. if you go here and view the source. [url="http://toppersbbs.dt...mapnet/blog.php"]http://toppersbbs.dt...mapnet/blog.php[/url] , now look at the top of the page, and look in side the <head> tags. You will see that I commented out 4 of the values set by nicedit in the <head> tags. There should only be one textarea setup for nicedit. How, go to [url="http://toppersbbs.dt...mapnet/blog/addentry.php"]http://toppersbbs.dt...mapnet/blog/addentry.php[/url] you will see again that only one textarea has been defined in the <head> tags, so if you down down the page and look for the <textarea id="area2">, Its all the way at the bottom of the page. You will see that it's does match and so from what I saw in the demo's. This should work. Well it doesn't Hint: This is up to you guys. If you want to. The new user register is up and running and I tested it over 20 + times. Doing this will stop the errors your getting on the pages, Undefined Indexes. You will get an email. and just click the link in the email. This will approved and activate your account. If you choose to do this. It's up to you. It will remove all the extra errors you have been getting when you didn't log in. I removed the security from the pages just so that you wouldn't have to register and login. Joe
Link to post
Share on other sites

you can see every thing just by clicking on view source. What other parts are there that you wanted to see. I did try and add the code right to the html page that I wanted the text box on, and I'll I got an an error that kbLib is undefined. and I know that has some thing to do with the javascript. Not the PHP code.

Edited by Bigjoe
Link to post
Share on other sites

For some reason all your links came out abbreviated, and not fully formed, so I am assuming this is the page in question.http://toppersbbs.dt...og/addentry.php if so, looking at in developer tools with Chrome, it is trying to find five files and can'tmissing.png

Edited by thescientist
Link to post
Share on other sites

Ok, I don't know eher your seeing these errors at. Yesterday I fixed the click.js and it works. now. I click on it and it works. Where before it didn't. heres the line I have in my <head> tags and it works. I didn't have to try and add it right to the page I wanted the the javascript to run at. I just tested it again a minute a go and it works. So I'm donwloading chrome and your going to have to tell me where you see the errors at. <script type="text/javascript" src="jscripts/click.js"></script> This is what I have in my <head> tages now and I can get the functions to work... UPDATE:I just downloaded and install google chrome and can you tell me where you see those erorrs at

Edited by Bigjoe
Link to post
Share on other sites
For some reason all your links came out abbreviated, and not fully formed, so I am assuming this is the page in question.http://toppersbbs.dt...og/addentry.php if so, looking at in developer tools with Chrome, it is trying to find five files and can'tmissing.png
Ok, I didn't know what else to do. So I added the complete and full path to all the files in the header. So look at it again and see if you done see those errors any more. And that fixed the style sheet too for the add entry too. So now it has all the colors it should and so. I'm going to try some of the other parts too to see if they work.
Link to post
Share on other sites

Ok, take a look at this. I we are getting closer. Any ideas why the drop down boxes don't work. and 1 question. As far as I know. I never had to put the full paths in the header before for the web site. I guess this is because I'ts all new and new to me. http://toppersbbs.dtdns.net/mapnet/blog/addentry.php?bid=21 The link above will show you that it's reading the style sheet and well some of the miceditor is working. Just not all of it.

Link to post
Share on other sites

well, typically while I develop I just keep the error console open so it runs everytime I make a change and refresh the page. You can do the same. Secondly, as mentioned already, you should validate your page. It looks like you have a lot of missing tags (closing/required) and most obvious, no ending body and html tags. Validation and error checking are the most basic fundamental debugging exercises for web development. I do them constantly as I develop. So much so that I have a validator plugin installed in Chrome so I can instantly see validation errors, and I use the console for lots of logging to check my javascript code. Spend some time cleaning things up and getting things together, and I bet a lot of your issues will shake themselves loose.

Link to post
Share on other sites
well, typically while I develop I just keep the error console open so it runs everytime I make a change and refresh the page. You can do the same.
what do you mean by 'error console open' I know what a console is. I don't know what that mean for web development.
Secondly, as mentioned already, you should validate your page. It looks like you have a lot of missing tags (closing/required) and most obvious, no ending body and html tags.
well the ending body and html tags are in the footer. How ever I don't all ways use the footer in every page
Validation and error checking are the most basic fundamental debugging exercises for web development. I do them constantly as I develop. So much so that I have a validator plugin installed in Chrome so I can instantly see validation errors, and I use the console for lots of logging to check my javascript code. Spend some time cleaning things up and getting things together, and I bet a lot of your issues will shake themselves loose.
Ok, well you been helping me so a lot of it. Now ever any idea wht the drop down boxes in the nicedit are blank or empty. Just to get the menu to show up. I had to put the full path into the micedit.js script to the menu icons. as far as I know this should be required,
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...