Jump to content

Valid Html And Css But .. Problems With Ie


talvi
 Share

Recommended Posts

I've tested the code on the validator and, after ironing out a couple of errors, both the html and the css are valid, but although the page displays perfectly in Firefox it looks a mess in IE. It's at: http://phoenixchange...newIndex000.php I've tested it on Litmus and their result is the same as what I get. Ive attached two screen shots, showing the first two problems. One is of FF9.0.1 (screenshot from my machine) that shows what I want, and the other shows the Litmus test result of IE7. The three problems in IE are that: 1. The inline "menu" on the top of the grey banner and on the right of the window, slips inboard2. The content of the page drops about 150px down from the fixed grey banner3. The fixed banner isn't fixed in IE post-89405-0-38704500-1326465014_thumb.jpg post-89405-0-83443100-1326465031_thumb.jpg I've been being helped by dsonesuk on another thread (on another topic) but have moved it here and in case it's of interest more generally

Edited by talvi
Link to comment
Share on other sites

LOOK! as pointed out before, but! I shall say this only ONCE MORE, as long as <!--******************* INDEX PAGE **********************-->is placed at the top of the page the doctype is ignored, and IE will revert to quirkes mode, which will force crappy IE to display as what you are seeing now!

  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...