Jump to content

Machine can't access Remote MySQL database anymore


Viper114
 Share

Recommended Posts

A few days ago, we had our Static IP address changed by our ISP. Since then, it seems a Debian machine we use to connect to a remote MySQL database and back it up is forbidden again from connecting to it since it was set to read by IP address. I've been trying to apply permission again to allow this machine to connect, but the database is refusing to allow it. I've tried the following:grant all on DBNAME.* to 'root'@'newipaddress' identified by 'password';flush privileges;When I test to see if it will work, I get the error 1045 "Access denied for user 'root'@'domainname' (using password: YES) when trying to connect". I've even tried the above but putting in the domain name instead of the IP address, but it still gets refused. I'm not sure what else to try. Any ideas?

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...