Jump to content

url class stylesheet problem


rawlin
 Share

Recommended Posts

Hi,I really can't figure this out, I got a stylesheet.css that I refer to in the header. It have worked perfectly until now. The problem I got is that for some reason it is not picking up new code in the stylesheet. What I don't get is why this works From stylesheet.css

a.nyheturl:link {color: blue; text-decoration: none; }a.nyheturl:visited {color: blue; text-decoration: none; }a.nyheturl:hover {color: blue; text-decoration: underline; }a.nyheturl:active {color: blue; }

and this does not From stylesheet.css

a.adminmenuurl:link {color: blue; text-decoration: none; }a.adminmenuurl:visited {color: blue; text-decoration: none; }a.adminmenuurl:hover {color: red; text-decoration: underline; }a.adminmenuurl:active {color: blue; text-decoration: none; }

Code on page

<? $urlclass="adminmenuurl"; ?><p class="m11" style="margin-bottom: 5px; margin-left: 10px; Float: left; text-align: center;"><a href="url" class="<? echo $urlclass; ?>">Text</a></p>

I really can't figure it out, any help is appreciated.

Link to comment
Share on other sites

Guest So Called

Looks like it should work. Are you sure you're picking up the right style sheet? Test that by changing some obvious style in the external style sheet, maybe the body background, just to see that the contents of the style sheet are actually being included in the document.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...