Jump to content

WRAP-OPTION Not Working


Recommended Posts

Hello, I'm trying to get the "wrap-option = 'wrap'" to work within a block.I have the following code:<fo:table-cell text-align="center"> <fo:block wrap-option="wrap"> <xsl:value-of select="MODIFIERS/MOD1"/> <fo:inline font-size="4pt"> </fo:inline> <xsl:value-of select="MODIFIERS/MOD2"/> <fo:inline font-size="4pt"> </fo:inline> <xsl:value-of select="MODIFIERS/MOD3"/> <fo:inline font-size="4pt"> </fo:inline> <xsl:value-of select="MODIFIERS/MOD4"/> </fo:block></fo:table-cell> The MOD4 is being cut off as it doesn't fit within the column.I don't want to make the column wider.I read somewhere not to have "keep-together='always'" on the table-row line and I do not have that property there. What do I need to do to get this column to wrap? Any help with this will be much appreciated! Thanks,Rita

Link to post
Share on other sites
Hello, I'm trying to get the "wrap-option = 'wrap'" to work within a block.I have the following code:<fo:table-cell text-align="center"> <fo:block wrap-option="wrap"> <xsl:value-of select="MODIFIERS/MOD1"/> <fo:inline font-size="4pt"> </fo:inline> <xsl:value-of select="MODIFIERS/MOD2"/> <fo:inline font-size="4pt"> </fo:inline> <xsl:value-of select="MODIFIERS/MOD3"/> <fo:inline font-size="4pt"> </fo:inline> <xsl:value-of select="MODIFIERS/MOD4"/> </fo:block></fo:table-cell> The MOD4 is being cut off as it doesn't fit within the column.I don't want to make the column wider.I read somewhere not to have "keep-together='always'" on the table-row line and I do not have that property there. What do I need to do to get this column to wrap? Any help with this will be much appreciated! Thanks,Rita
Hmmm - I just changed "text-align='right'" and this time all the MODiFIERS were printed correctly in the column. Works fine when there are 4 modifiers but most times there will just be one or two and so I need to have the text aligned center.
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...