Jump to content

uploading big files with ftp


Ustag
 Share

Recommended Posts

I've found many topics on how to fix this but nothing seem to work for me.I am uploading files trough ftp with a php script and what I am doing to make this work so far is this: editing .htaccess to make php settings allow a file of 10mb for sure:

php_value session.gc_maxlifetime 86400php_value max_input_time 86400php_value max_execution_time 86400php_value upload_max_filesize 1100Mphp_value post_max_size 1100Mphp_value memory_limit 1100M

Using custom timeout setting like this:ftp_connect($ftp_server, 21, 120000) Editing the same options as above in the actual php.ini file. I also have this in my php script: set_time_limit(0);And this: ini_set('upload_max_filesize',1100000000); What I get now is this error message when trying to upload a file of around 10mb: POST Content-Length of 10550339 bytes exceeds the limit of 10485760 bytes in Unknown on line 0 If I look in phpinfo(); ite tells me that post_max_size = 10M and upload_max_filesize = 10M even if I changed it. How come? Could it be my webhost that prevents this from increasing???

Edited by Ustag
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...