Jump to content
Sign in to follow this  
salman.pirani

Average code is not working

Recommended Posts

Please Help Error

SELECT AVG® AS Average FROM tform WHERE pt='Taming the Time Monster'

Microsoft OLE DB Provider for SQL Server error '80040e07'

The average aggregate operation cannot take a varchar data type as an argument.

/hr/tform/admin/avrage.asp, line 20

Code<%strConnect ="Provider=SQLOLEDB.1;Persist Security Info=False;User ID=usrtform;Initial Catalog=hrtform;Data Source=intranet;pwd=tform123"set cn= server.createobject("adodb.connection")set rs=server.createobject("adodb.recordset")cn.open strConnect sql="SELECT AVG® AS Average FROM tform WHERE pt='" & Request.Form("id") & "'"response.Write(sql)set rs=cn.execute(sql) %> <% do until rs.EOF%><tr> <%for each x in rs.Fields%> <td><%Response.Write(x.value)%></td> <%next rs.MoveNext%></tr> <%looprs.closecn.close%>

Share this post


Link to post
Share on other sites

The error message is pretty self-explanatory: The average aggregate operation cannot take a varchar data type as an argument.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...