Jump to content

is there any other way than overflow:hidden to hide scrollbars


Recommended Posts

Overflow: hidden is the way it's done. The only other way to prevent scroll bars is to make sure your content isn't too long.

 

Why isn't the overflow property an option? There are many ways to do it:

In the stylesheet:

body { overflow: hidden; }

In the HTML document:

<style type="text/css">body { overflow: hidden; }</style>

On the element itself:

<body style="overflow: hidden;">

Using Javascript:

<script>document.body.style.overflow = "hidden";</script>
Link to post
Share on other sites

basically my problem is after running my project, at right side there is Blurred vertical scrollbar after doing overflow:hidden on body. this problem arises in IE only and because of that my datagrid alignment is disturbing. and that's why i am searching for alternative method for overflow property. in all other browsers it's working excellent but IE created problems. and there is no chance of reducing size of content.

Edited by rhishi20
Link to post
Share on other sites

How does Internet Explorer's bar interfere? If your page is fluid a tiny bit less space on the side wouldn't change much. Maybe a screenshot or an onlin example could help explain the problem.

Link to post
Share on other sites

http://www.imapg.com/vtrial/myimg/problemIE.bmp

 

this is where i have put screenshot of website where you can see at right side blurred vertical scrollbar.

 

and now i have found another interesting thing i thought that blur vertical scrollbar came because of i have done overflow:hidden on body but this is not a case.

 

see following link on which my login page also came with blurred vertical scrollbar.

 

http://www.imapg.com/vtrial/myimg/loginpageIE.bmp

 

and now see my Firefox login page on following link

 

http://www.imapg.com/vtrial/myimg/loginpagefirefox.bmp

 

here you can see no vertical scrollbar.

 

also see website's perfect view as i wanted done in Firefox below

 

http://www.imapg.com/vtrial/myimg/perfectfirefox.bmp

Edited by rhishi20
Link to post
Share on other sites

have you seen my all 4 images ?

 

if you compare 1st & 4th image you can see alignment of gridview header and Gridview not matching with each other in 1st image. and now consider that vertical scrollbar is not present there. you can imagine gridview header and gridview will perfectly match with each other. you can see 4th image that vertical scrollbar is not present on body, it is on div in which gridview is present. and alignment of Gridview and Gridview Header perfectly match with each other.

 

just consider i want to just delete that blurred vertical scrollbar which is coming in only IE with every single page

(loginpage, assemblypage)which is appearing without any coding

Edited by rhishi20
Link to post
Share on other sites

if you are asking about my gridview content, that's not the issue i have just keep div's height less that's why lesser content showing. if i increase size of div it will be full of page.

 

I also thought that may be because of extra height of background image, vertical scrollbar is coming. so i have removed background image from login page but strange thing is vertical scrollbar is still showing on login page.

Edited by rhishi20
Link to post
Share on other sites

This only issue with IE7 and below isn't it?

four options

1) use IE browser above version 7

2) seriously, use a IE browser above version 7

3) make the scrollbar appear on all browsers

4) or try something like

        <!--[if lte IE 7]>        <style type="text/css">html, body{min-height:100%;margin:0px;padding:0px;overflow:hidden;} html:hover,body:hover {overflow:auto;}        </style><![endif]-->
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...