Jump to content
ramf

How to enable mysqli support when installing vtiger 6.2.0 on windows 8.1?

Recommended Posts

Hope you can help. I'm trying to install vtiger 6.2.0 on windows 8.1 - during the installation wizard there is the part with the required values testing.

In this part everything is set to "yes" except mysqli support that appear as "no" under the present value.

In the PHP.ini in C:Program Files (x86)vtigerCRM620php under Dynamic Extensions the line extension=php_mysqli.dll is without ; before it.

in the PHP.ini in C:Program Files (x86)vtigerCRM620apachehtdocsvtigerCRMpkgphp under Dynamic Extensions there is no extension=php_mysqli.dll so I added it to the end of the column.

Still the mysqli support appears as "no" under the present value.

By the way - I don't have a section marked [php_MYSQLI] in my PHP.ini files - the only place that have something to do with php_mysqli.dll is in the ;;;;;;;;;;;;;;;;;;;;;; ; Dynamic Extensions ; section. ;;;;;;;;;;;;;;;;;;;;;;

what should I do?

By the way (2) - the Required Value of PHP Version is 5.5.0 and the Present Value is 5.3.10 (this is the php that comes with the vtiger installation EXE file). I wonder if 5.5.0 is the required value of PHP - why the exe install 5.3.10?

Thanks for your help! Ram

Share this post


Link to post
Share on other sites

In order to enable an extension you need to have the extension line in the php.ini file to load that extension, and it needs to point to a valid extension file. Make sure the file actually exists. You can also configure PHP to report startup errors to an error log, you can check that log to see if there are any errors with startup.

Share this post


Link to post
Share on other sites

In order to enable an extension you need to have the extension line in the php.ini file to load that extension, , and it needs to point to a valid extension file You can also configure PHP to report startup errors to an error log, you can check that log to see if there are any errors with startup.

Hi,

Thanks for the reply.

 

1.I have the extension line in the php.ini file both in C:Program Files (x86)vtigerCRM620php and in C:Program Files (x86)vtigerCRM620apachehtdocsvtigerCRMpkgphp. (there is extension=php_mysqli.dll under the Dynamic Extensions section - without ";" at the beginning of the line- but still I get this error when trying to install Vtiger.

 

2. what do you mean by ", and it needs to point to a valid extension file" - what file do I need to have? where should it be? what do I have to check other than the extension part in the PHP.INI?

 

3. Can you please explain how to enable this log?

 

Thanks!!

Ram

Share this post


Link to post
Share on other sites

what file do I need to have?

The .dll file you're telling it to load.

where should it be?

Inside the extension directory, which is defined in php.ini.http://php.net/manual/en/install.windows.extensions.php

3. Can you please explain how to enable this log?

There are several options in php.ini that relate to error handling. I would recommend that you go through that entire file and look at every setting. You can look up the settings on php.net if you don't know what they do. You can change PHP to work exactly like you want it to work, and you'll have a better understanding of what it does.

Share this post


Link to post
Share on other sites

The .dll file you're telling it to load.Inside the extension directory, which is defined in php.ini.http://php.net/manual/en/install.windows.extensions.phpThere are several options in php.ini that relate to error handling. I would recommend that you go through that entire file and look at every setting. You can look up the settings on php.net if you don't know what they do. You can change PHP to work exactly like you want it to work, and you'll have a better understanding of what it does.

Hi,

Thanks for your answer.

 

The extension directory in the php.ini in:C:Program Files (x86)vtigerCRM620php is set to: "C:Program Files (x86)vtigerCRM620phpext" in that directory there is a file "php_mysqli.dll" - so it seems o.k.

The extension directory in the php.ini in C:Program Files (x86)vtigerCRM620apachehtdocsvtigerCRMpkgphp is set to "extension_dir = "VTIGER_HOMEphpext" should I change it to "C:Program Files (x86)vtigerCRM620phpext"?

 

Do I need the php.ini to be the same in both folders?

 

Here I see that:

php_mysqli.dll MySQLi functions Requires libmysql.dll (libmysqli.dll in PHP <= 5.0.2) (bundled)

 

Do I need to have libmysql.dll as well?

I found this file "libmysql.dll" in C:Program Files (x86)vtigerCRM620mysqlbin - this is the right file in the right location?

 

Thanks!

Share this post


Link to post
Share on other sites

You need to figure out which php.ini it is using. If you create a phpinfo page, near the top it will tell you which php.ini it is using. You need to make any changes to that file.

Do I need to have libmysql.dll as well?

It sounds like that file is already bundled.

Share this post


Link to post
Share on other sites

You need to figure out which php.ini it is using. If you create a phpinfo page, near the top it will tell you which php.ini it is using. You need to make any changes to that file.It sounds like that file is already bundled.

 

Great - I don't know how exactly but after checking, rechecking and then checking again (and in all the checking all the settings were o.k.) - and after several installing, removing and then installing again - finally (and strangely) there is no error regarding mysqli support (the only thing is the issue with the required value of PHP version that is 5.5.0 and the present value is 5.3.10 ) - but since the PHP is part of the vtiger's installation EXE - I guess that's o.k.

 

Thanks for your help!

Ram

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...