Jump to content

Website loads strang on iPad after update IOS9


Peter64
 Share

Recommended Posts

I have tried to create a website http://markgeessink-classiccars.com/ on this worked fine on iPad untill the iPad has been updated to IOS 9. After the update the side loads in half pages and blocks. After some time the site expands so the whole screen is filled and works fine. Befor the update there wasn't a problem. Could any one tell me how I could solve this problem. As tags I have choosen html, css and js because I don't know what causes the problem. Sorry for that.

 

Thanks

Link to comment
Share on other sites

Simple the page is bloated and takes too long to fully load. How bloat that clogs the pipe is resolved is different across operating systems, browsers and different versions of both.

 

The solution to reduce the load time by removing some of the bloat. You noticeds the problem on an Ipad, but there are probably other platform combinations with issues.

 

It would be a benefit to speed up laoding anyway, because the slow load is probably costing you traffic. An animated loading cartoon, is not going to haold any users; all it does is add a little more overhead.

  • Like 1
Link to comment
Share on other sites

Thanx for your reply. Needless to say but this is all kind of new for me and I have tried to build this for an acquaintance of mine. I ran the script through https://validator.w3.org/ and https://developers.google.com/ and it all seems fine. On iPad It looked fine untill it was updated from ios 8 to ios 9. How could I remove bloat, is his a matter of removing images or should I look a different way. ( my acquaintance loves his cars and want to show as much as possible of them )

 

Thanx again

Link to comment
Share on other sites

Dsonesuk thanks for the Reply,

 

This is the exact same problem. I have changed:

<meta name="viewport" id="viewport" content="width=device-width,target-densitydpi=high-dpi,initial-scale=1.0,user-scalable=no"/>

to:

  <meta name="viewport" content="initial-scale=1.0001, minimum-scale=1.0001, maximum-scale=1.0001, user-scalable=no"/>

and now the problem is solved. Could anyone tell me why the second line is fixing this problem? I know it helps and that is the important thing, but it would be great to know why it is helping.

 

Dsonesuk again many thanks for your help.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...