Jump to content

Apache Soap Problem


alwaysvaghu
 Share

Recommended Posts

Hello friends....I have configure my apache soap..... It is saying that after configuration if i go on "http://localhost:8080/soap/servlet/rpcrouter" it will give following message......"Sorry, I don't speak via HTTP GET- you have to use HTTP POST to talk to me."But in my case it is throwing exception which is pasted below...I am using tomcat apache server... soap 2.3.1My class path is: set classpath=C:\Jars\bsf.jar;C:\Jars\js.jar;C:\Jars\activation.jar;C:\Jars\xerces.jar;C:\Jars\activation.jar;C:\Jars\soap-bin-2.3.1\soap-2_3_1\lib\soap.jar;C:\Jars\soap-bin-2.3.1\soap-2_3_1;C:\Jars\javamail-1_4\javamail-1.4\mail.jar;C:\ch3;C:\Program Files\Java\jdk1.5.0_04\lib\tools.jar;C:\Program Files\Java\jdk1.5.0_04\jre\lib\javaws.jar;C:\Program Files\Java\jdk1.5.0_04\jre\lib\rt.jar;and Exception is:======================================================type Exception reportmessage description The server encountered an internal error () that prevented it from fulfilling this request.exception javax.servlet.ServletException: Servlet.init() for servlet rpcrouter threw exception org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:117) org.apache.catalina.valves.AccessLogValve.invoke(AccessLogValve.java:535) org.apache.coyote.tomcat5.CoyoteAdapter.service(CoyoteAdapter.java:160) org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:790) org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.processConnection(Http11Protocol.java:709) org.apache.tomcat.util.net.TcpWorkerThread.runIt(PoolTcpEndpoint.java:572) org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:644) java.lang.Thread.run(Thread.java:595)root cause java.lang.NoClassDefFoundError: javax/mail/MessagingException org.apache.soap.server.http.RPCRouterServlet.init(RPCRouterServlet.java:239) javax.servlet.GenericServlet.init(GenericServlet.java:256) org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:117) org.apache.catalina.valves.AccessLogValve.invoke(AccessLogValve.java:535) org.apache.coyote.tomcat5.CoyoteAdapter.service(CoyoteAdapter.java:160) org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:790) org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.processConnection(Http11Protocol.java:709) org.apache.tomcat.util.net.TcpWorkerThread.runIt(PoolTcpEndpoint.java:572) org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:644) java.lang.Thread.run(Thread.java:595)note The full stack trace of the root cause is available in the Tomcat logs.==================================================Please help me as soon as possible... Pleaaaaaaaase

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...