Jump to content

XAMPP: Apache Module Not Working


Recommended Posts

Hello everyone. I tried to install and configure PHP and MySQL for use on my own website using XAMPP. However, the Apache module gives me an error each time I try to start it.

10:40:53  [main] 	Starting Check-Timer
10:40:53  [main] 	Control Panel Ready
10:41:07  [Apache] 	Problem detected!
10:41:07  [Apache] 	Port 80 in use by "Unable to open process" with PID 4!
10:41:07  [Apache] 	Apache WILL NOT start without the configured ports free!
10:41:07  [Apache] 	You need to uninstall/disable/reconfigure the blocking application
10:41:07  [Apache] 	or reconfigure Apache and the Control Panel to listen on a different port
10:41:07  [Apache] 	Attempting to start Apache app...
10:41:07  [Apache] 	Status change detected: running
10:41:10  [Apache] 	Status change detected: stopped
10:41:10  [Apache] 	Error: Apache shutdown unexpectedly.
10:41:10  [Apache] 	This may be due to a blocked port, missing dependencies, 
10:41:10  [Apache] 	improper privileges, a crash, or a shutdown by another method.
10:41:10  [Apache] 	Press the Logs button to view error logs and check
10:41:10  [Apache] 	the Windows Event Viewer for more clues
10:41:10  [Apache] 	If you need more help, copy and post this
10:41:10  [Apache] 	entire log window on the forums 

As the log said, I have to find and uninstall, disable or reconfigure the application which is blocking Port 80 or reconfigure Apache and the Control Panel to listen to a different port.

The question is: What should I do? Should I change port or should I find the blocking application? And if the latter, which application could be blocking Port 80?

Edited by Daniel On The Web
Link to post
Share on other sites

Ok. I went through the file httpd.conf of the Apache Module and changed the port to listen from. Now it's port 81. And it worked. However, when I type http://localhost I found an error 404 even with Apache activated. And what I am supposed to see is the XAMPP page. What else do I have to do?

 

Edit: I changed the main port for Apache to 81 as well and typed http://localhost:81. This took me to the XAMPP page. Now I have to configure PHP and Apache so I can use them in my website.

Edited by Daniel On The Web
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...