Jump to content

Database Connection Issue


Recommended Posts

User name: any

Host name: localhost

Password: no

Global privileges: usage

User group: -

Grant: no

 

User name: pma

Host name: localhost

Password: no

Global privileges: usage

User group: -

Grant: no

 

User name: root

Host name: 127.0.0.1

Password: no

Global privileges: all privileges

User group: -

Grant: yes

 

User name: root

Host name: ::1

Password: no

Global privileges: all privileges

User group: -

Grant: yes

 

User name: root

Host name: localhost

Password: no

Global privileges: all privileges

User group: -

Grant: yes

Edited by Daniel On The Web
Link to post
Share on other sites

It sounds like you're still not using the correct port. The message that the machine actively refused the connections means that your connection attempt was explicitly blocked. It's not a permission issue because the attempt to even connect failed, it never had a chance to log in at all. Maybe compare the connection settings inside the phpmyadmin config file to see how that's set to connect.

Link to post
Share on other sites

As I thought I did something wrong, I decided to start over on a Mac. PHP works even without XAMPP, so I believe that the service to upload my webpage supports PHP.

 

Now I'm thinking about reinstalling MySQL and phpMyAdmin in the Mac and test it again.

 

Anyway, useful info to check what's the right port.

Edited by Daniel On The Web
Link to post
Share on other sites
  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...