Jump to content

Hovering a mega menu does not show on top of the wepage image.


Recommended Posts

Hi,

I have this mega menu that can be hovered over the parent items.
When hover over a parent item on top of the screen the view with sub-items is shown.
Unfortunately this screen is not shown on top of the wepage that contains an image with a textblock.
I get the feeling that it is behind the the image on the page instead off on top.

Does anybody have any idea what is causing this issue?
The code I use you can find in the attached html file.  

menu-test-w3.html

Link to post
Share on other sites

Usually positioning and z-index layer level problem.

If you have nav sibling container and a content sibling container i.e nav above content container. The nav (with child menus) with position: relative/sticky etc with a higher z-index than below content sibling container of position: relative; (this is usually all that is required without the need for z-index being set). The nav and its child menu should show above the content sibling AND children elements within it.

  • Like 1
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...