Jump to content
Buffygabriel

Executing Example ASP from W3 but get Page Not Found.

Recommended Posts

I am trying to learn to use ASP and have followed the example in the ASP tutorial on W3 as follows. But when I open my browser and type in "http://localhost/MyWeb/test1.asp: I get Page not Found. The content of my Test1.asp file is<html><body><%response.write("Hello World!")%></body></html>I know my IIS is running because if I point my browser to a index.htm file it does pull up a web page.Please help a newby.Thanks Toflyhi How to install IIS and run ASP on Windows XP ProfessionalNote: You cannot run ASP on Windows XP Home Edition.Insert the Windows XP Professional CD-Rom into your CD-Rom Drive From your Start Button, go to Settings, and Control Panel In the Control Panel window select Add/Remove Programs In the Add/Remove window select Add/Remove Windows Components In the Wizard window check Internet Information Services, click OK An Inetpub folder will be created on your harddrive Open the Inetpub folder, and find a folder named wwwroot Create a new folder, like "MyWeb", under wwwroot. Use a text editor to write some ASP code, save the file as "test1.asp" in the "MyWeb" folder Make sure your Web server is running - its status can be checked by going into the Control Panel, then Administrative Tools, and double-click the "IIS Manager" icon Open your browser and type in "http://localhost/MyWeb/test1.asp", to view your first ASP page

Share this post


Link to post
Share on other sites
you have windows XP professional?Be sure ASP is enabled in IIS
Yes I have XP Professional, but I have not been able to find out where enable ASP. I found info that told me how to do it on a server (in Control Panel,Admin Tools, IIS Manager)but not I can not find IIS Manager on my local machine. Can you tell me where to find ASP locally.

Share this post


Link to post
Share on other sites

If you're testing this with IE, test it with Firefox or Opera instead. IE shows generic error messages, you are probably getting an ASP error that you can't see with IE.

Share this post


Link to post
Share on other sites
Yes I have XP Professional, but I have not been able to find out where enable ASP. I found info that told me how to do it on a server (in Control Panel,Admin Tools, IIS Manager)but not I can not find IIS Manager on my local machine. Can you tell me where to find ASP locally.
You may not have IIS installed (it isn't by deafult) have you manually installed IIS? If not put in your windows cd and choose install windows components and check Internet Information Services, then install.If you already have IIS installed it should be under Control Panel> Administrative Tools>Internet Information Services.

Share this post


Link to post
Share on other sites
If you're testing this with IE, test it with Firefox or Opera instead. IE shows generic error messages, you are probably getting an ASP error that you can't see with IE.
I have done what you suggested and I get the following error in both browsers. Server Application ErrorThe server has encountered an error while loading an application during the processing of your request. Please refer to the event log for more detail information. Please contact the server administrator for assistance.I checked the system log and am getting the following entry each time I try to access the c:\inetpub\wwwroot\myweb\test1.asp with my browser.The server failed to load application '/LM/W3SVC/1/Root/MyWeb'. The error was 'Class not registered'. I think I am in over my head.\Thank you for your help.
You may not have IIS installed (it isn't by deafult) have you manually installed IIS? If not put in your windows cd and choose install windows components and check Internet Information Services, then install.If you already have IIS installed it should be under Control Panel> Administrative Tools>Internet Information Services.
I do have IIS installed. Under Administrative Tools>Internet Information Services I can navigate to MYWeb and there is a tab for ASP.net and It looks like it is enabled.Thanks for your help.

Share this post


Link to post
Share on other sites

are you trying to run ASP or ASP.Net? They are 2 very differnt things.When you are in IIS manager expand the treeview until you see a node that says Web Server Extensions or somethign similar.Click this node once. You should get, to the right, a list of extensions saying either allowed or prohibited.If you are running ASP.Net then that extension must be allowed if you are running Classic ASP then the extension named Active Server Pages must be allowed.

Share this post


Link to post
Share on other sites
are you trying to run ASP or ASP.Net? They are 2 very differnt things.When you are in IIS manager expand the treeview until you see a node that says Web Server Extensions or somethign similar.Click this node once. You should get, to the right, a list of extensions saying either allowed or prohibited.If you are running ASP.Net then that extension must be allowed if you are running Classic ASP then the extension named Active Server Pages must be allowed.
In windows XP pro I do not have IIS Manager like there is in a server, in Administrative tools I only have IIS. I cannot locate anyplace in IIS that has a web server extensions tab or that can allow ASP.

Share this post


Link to post
Share on other sites

Inside your IIS (under Administrative Tools) do you have the Web Service Extensions node (highlighted in below picture?If not I will check my XP Pro machine tonight and get back to you on how to do the same thing. I only have access to a Server 2003 machine right now.iiseo2.gif

Share this post


Link to post
Share on other sites
Guest ASPnewb

I'm having exactly the same issue, actually. IIS is definitely running (service is activated), but in my IIS Manager I'm only seeing the "Web Sites" and "Default SMTP Virtual Server" nodes. I'm running XP Professional.-A

Inside your IIS (under Administrative Tools) do you have the Web Service Extensions node (highlighted in below picture?If not I will check my XP Pro machine tonight and get back to you on how to do the same thing. I only have access to a Server 2003 machine right now.iiseo2.gif

Share this post


Link to post
Share on other sites
I'm having exactly the same issue, actually. IIS is definitely running (service is activated), but in my IIS Manager I'm only seeing the "Web Sites" and "Default SMTP Virtual Server" nodes. I'm running XP Professional.-A
This might help. Go to IIS>Websites>MyWeb.1) right click on Myweb.2) properties. 3) I am not sure exactly what is says, But you have to create the MYweb as application.4) if already created, Remove and Recreate again. 5) Now browse to the page and see. http://localhost/MyWeb/test1.asp

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...