Jump to content
Sign in to follow this  
congosamurai

Problem with IE6 & 7 and active x

Recommended Posts

Hello.Well, this problem has really been giving me a hard time for the past 3 days. Here it is...I'm using Dreamweaver 8 to hand code a site and then using Flash 8 Pro to build a basic flash photo slide show and have it imported into the home page. That's it.Problem:It works in every browser except for IE 6 & 7. Whenever I try to test the file localy, I get that yellow bar at near the top of the browser that warns me about Active X control. I then have to click it and allow the blocked content which in turn causes IE to ask me again if I'm sure. After all of this, the flash works just fine.Status:I've downloaded every single Adobe update and have applied them all. I've gone into flash 8 and told it to publish the .swf file with the "active content update" and even ran the command that places that javascript file in the root folder.I've downloaded the Dreamweaver 8 update as well and it just inserts the same script. I've lowered my IE settings just in case and still nothing. I'm really having a hard time with this one and would appreciate any and all help that can be given to me. <script type="text/javascript">AC_FL_RunContent( 'codebase','http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=7,0,19,0','width','550','height','400','src','images/slideshowfinal2','quality','high','pluginspage','http://www.macromedia.com/go/getflashplayer','movie','images/slideshowfinal2' ); //end AC code</script><noscript><object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=7,0,19,0" width="550" height="400"> <param name="movie" value="images/slideshowfinal2.swf" /> <param name="quality" value="high" /> <embed src="images/slideshowfinal2.swf" quality="high" pluginspage="http://www.macromedia.com/go/getflashplayer" type="application/x-shockwave-flash" width="550" height="400"></embed></object></noscript>Above: This is what I get when insert the .swf file through Dreamweaver. It also places a script tag in the head of the html which calls for the AC_RunActiveContent.js script.Thanks again.

Share this post


Link to post
Share on other sites

this is an IE setting that automattically blocks popups and ActiveX components until you consent to running them.Go to Tools -> Internet Options -> Security -> Custom LevelFrom here you can adjust the ActiveX/plug-in options.

Share this post


Link to post
Share on other sites

I checked that out. I went into my laptop, IE6 and on my home pc, IE7 and set them all to custom. I then went in and told it to accept every Active X option and not to prompt for anything. I still get the same thing.I can't shake the feeling that this has something to do with my flash show or something that I did wrong but that is what flash 8 is generating.Could it have something to do with the fact that I'm running them localy off my hdd and not a web server?And here's another thing. When I publish my flash content, it also generated a .html file of my slideshow. When I open that in IE, it runs just fine without prompting me.

Share this post


Link to post
Share on other sites
I checked that out. I went into my laptop, IE6 and on my home pc, IE7 and set them all to custom. I then went in and told it to accept every Active X option and not to prompt for anything. I still get the same thing.I can't shake the feeling that this has something to do with my flash show or something that I did wrong but that is what flash 8 is generating.Could it have something to do with the fact that I'm running them localy off my hdd and not a web server?
I doubt it is flash..I get the prompts when I use opacity/filter in CSS, it is just some settings of IE.I thought my suggestion would solve your probelm, sorry, not sure where else to look.

Share this post


Link to post
Share on other sites

Try Tools>Internet Options>Advanced and check "Allow active content from CDs to run on my computer" and "Allow active content to run in files on my computer". Restart IE and try again. Theese setting apply only on the local file system. On the web, they don't.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...