Jump to content

Firefox does not open images


Janno
 Share

Recommended Posts

I'm just beginning with HTML. I wrote a short script, containing just an image and some text.The script works fine in Internet Explorer.I had it validated with the W3C-validator, and the syntax is OK.But when I do use Firefox the picture is not shown.I'm using XP SP 2 on a P4-3000, Norton Internet Security is running,both browsers are updated to the newest versions.I cleared the cache. I changed the picture. But no img in Firefox.What is wrong?Here's the script:<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" "http://www.w3.org/TR/html4/loose.dtd"><html><head><title>OEF1</title><meta http-equiv="Content-Type" content="text/html; charset=utf-8"></head><body bgcolor="#eeebaa"><div align="center"><img src="C:\Documents and Settings\Jan\Mijn documenten\Mijn afbeeldingen\fluitengeltje.jpg" alt="dit is een plaatje"></div><br><br><br><br><p align="center">My Bonnie lies over the ocean.<br><br>My Bonnie lies over the sea.<br><br>My Bonnie lies over the ocean.<br><br>Oh, bring back my Bonnie to me.</p><p> <a href="http://validator.w3.org/check?uri=referer"><img src="http://www.w3.org/Icons/valid-html401" alt="Valid HTML 4.01 Transitional" height="31" width="88"></a> </p> </body></html>

Link to comment
Share on other sites

try using a relative link as well..put the image in the same folder as the web pagethen you can simply use this<img src="fluitengeltje.jpg" alt="dit is een plaatje" />if firefox isn't opening up images..try a webpage, if they dont work in any website, then you have images turned off.:)

Link to comment
Share on other sites

try using a relative link as well..put the image in the same folder as the web pagethen you can simply use this<img src="fluitengeltje.jpg" alt="dit is een plaatje" />
Yea, that's definitely the better solution. To further the suggestion, create a directory called "images" in the same directory where your web page is and put your images in there. Then you can use:
<img src="images/fluitengeltje.jpg" alt="dit is een plaatje" />

Link to comment
Share on other sites

Yea, that's definitely the better solution. To further the suggestion, create a directory called "images" in the same directory where your web page is and put your images in there. Then you can use:
<img src="images/fluitengeltje.jpg" alt="dit is een plaatje" />

Which happens to be working! Thanks.Just a "dummy"-question remains:The syntax of the script has been validated (W3C) and proved to be correct.IE does work finewith the script, but FF did not.What's (regarding this simple script) the value of the W3C-validation?
Link to comment
Share on other sites

You must remember: The W3C validator checks your syntax. It saw this:directory:\subdirectory:\name.extensionAnd said it was a valid entry--and it is.Also, the W3C validator is sometimes used more for aesthetic purposes---so you can stick a big ol' tag on your site saying "VALIDATED!"

Link to comment
Share on other sites

Yeh, this is something you need to watch out for, i did it when I was first learning code, I used \ instead of / which will stop it working on FF, IE doesn't mind but it is not strictly valid. On a computer it uses \ but on the web it uses /.I don't really know why, but I am sure there is a valid reason behind it.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...