Jump to content

Hover tag problems


Recommended Posts

I'm very new to css and and i'm having issues with having two different classes for hovering over links.This is the website:http://www.flatballphoto.co.uk/lpdc/index.phpThis is the relevant css:

a:link {	color: #15428D;}a:visited {  color: #3A79E2;}a:hover {	text-decoration: none;}a.menulink {	color: #ffffff;	font-weight: bold;	font-size: 12px;	text-decoration: none;	padding: 3px;	font-variant: small-caps;	text-align: centre;}a.menulink:visited {	color: #ffffff;}a.menulink:hovor {	text-decoration: underline;	background-color: #000000;}

The links in the main text should have an underline which will disappear when the link is hovered over. The links in the menu should have no text decoration but should have an underline (and hopefully an overline too) when they are hovered over.This is what i have in the css file but i can't work out why it doesn't work. The classes seem to be allocated properly so i'm baffled, what am i doing wrong?

Link to post
Share on other sites
I'm very new to css and and i'm having issues with having two different classes for hovering over links.This is the website:http://www.flatballphoto.co.uk/lpdc/index.phpThis is the relevant css:
a:link {	color: #15428D;}a:visited {  color: #3A79E2;}a:hover {	text-decoration: none;}a.menulink {	color: #ffffff;	font-weight: bold;	font-size: 12px;	text-decoration: none;	padding: 3px;	font-variant: small-caps;	text-align: centre;}a.menulink:visited {	color: #ffffff;}a.menulink:hovor {	text-decoration: underline;	background-color: #000000;}

The links in the main text should have an underline which will disappear when the link is hovered over. The links in the menu should have no text decoration but should have an underline (and hopefully an overline too) when they are hovered over.This is what i have in the css file but i can't work out why it doesn't work. The classes seem to be allocated properly so i'm baffled, what am i doing wrong?

There's no problem w/ the hover, I just saw the link having no underline when hovered
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...