sawild

Members
  • Content count

    5
  • Joined

  • Last visited

Community Reputation

0 Neutral

About sawild

  • Rank
    Newbie
  1. When I hit Post to the guestbook, it redirects to: http://damienbt.com/cgi-bin/guestbook.cgi and the page stays blank.
  2. Hi all! I'm attempting to put a guestbook on my website. I've been following the script from "http://articles.techrepublic.com.com/5100-22_11-5076796.html".However, I'm obviously doing something wrong as once I hit submit, it goes to the file in the cgi-bin and doesn't go any further. I'm left with a blank screen. Please help! It's driving me crazy! <form method="post" action="/cgi-bin/guestbook.cgi"> <p class="tags">Name: <input type="text" name="name" id="name" size="30" /></p> <p class="tags">E-mail address: <input type="text" name="email" id="email" size="30" /></p> <p class="tags">Website: <input type="text" name="website" id="website" /></p> <p class="tags">Comment: <textarea name="comment" id="comment" rows=3 cols=45 wrap=virtual></textarea></p> <br /> <input type="submit" name="submit" value="POST to the guestbook"> <input type="reset" name="reset" value="CLEAR the form" /> </form> <!--add--> #!/usr/bin/perl#variables that will be used later.$guestbookreal = "guest.html";$return = "http://www.damienbt.com/guest.html";read(STDIN, $buffer, $ENV{'CONTENT_LENGTH'});@pairs = split(/&/, $buffer);foreach $pair(@pairs) { ($name, $value) = split(/=/, $pair); $value =~ tr/+/ /; $value =~ s/%([a-fA-F0-9][a-fA-F0-9])/pack("C", hex($1))/eg; $value =~ s/<\!\-\-.*\-\->//g; # get rid of SSI $in{$name} = $value; }open (FILE,"$guestbookreal"); @LINES=<FILE>; chop (@LINES); close(FILE); $SIZE=@LINES;open (GUEST,">$guestbookreal");for ($i=0;$i<=$SIZE;$i++) { $_=$LINES[$i]; print GUEST "$_\n"; if (/<!--add-->/) { if ($in{'email'} ne '') { print GUEST "<b><a href=\"mailto:$in{'email'}\">"; print GUEST "$in{'name'}</a></b>:<br>\n"; } else { print GUEST "<b>$in{'name'}</b>:<br>\n"; } if ($in{'website'} ne '') { print GUEST "<a href=\"$in{'website'}\">"; } print GUEST "$in{'comment'}<p>\n"; } }close (GUEST);print "Location: $return\n\n";
  3. Didn't work. But thanks for the suggestion.
  4. Awesome! I'll give it a try and report back. Thanks!
  5. Hi Guys!So this one is driving me crazy! I have two links and they are set so that when someone hovers over them they change color. Without the <a> tag they worked great. When I add the <a> tag and when you click on the links a 1px dot appears in each corner. It only happens in firefox. Safari and IE don't have this problem. Anyone have any suggestions? here is the relevant css: div.bottombuttons a> p.bottomlink { font-family: Perpetua Titling MT; font-weight: bold; font-size: 10pt; color: #F10990; text-align: center; line-height: 35px;}div.bottombuttons a> p.bottomlink { margin: 0 auto;}div.bottombuttons a:hover > p.bottomlink { display: block;}div.bottombuttons a:hover > p.bottomlink { color: black; font-family: Perpetua Titling MT; font-size: 10pt; font-weight: bold; text-align: center; text-decoration: none; outline: none; border: 0px;}a{text-decoration: none;} Thanks a lot!