Jump to content

harry_ord

Members
  • Content Count

    117
  • Joined

  • Last visited

Everything posted by harry_ord

  1. I dowloaded the following project from github: https://github.com/deadwheel/FoodDelivery I did the following steps: 1- Downloaded the files via git bash to my xamppp'shtdocs folder: $ git clone https://github.com/deadwheel/FoodDelivery.git 2- Created the database forge on phpmyadmin. 3- I modified the config/database.php on the project's folder leaving it like this: 'mysql' => [ 'driver' => 'mysql', 'host' => env('DB_HOST', '127.0.0.1'), 'port' => env('DB_PORT', '3306'), 'database' => env('DB_DATABASE', 'forge'), 'username' => env('DB_USERNAME', 'root'), 'password' => env('DB_PASSWORD', ''), 'unix_socket' => env('DB_SOCKET', ''), 'charset' => 'utf8mb4', 'collation' => 'utf8mb4_unicode_ci', 'prefix' => '', 'strict' => false, 'engine' => 'innoDB', ], 4- Input the following commands: $ composer update $ php artisan migrate With this, all the tables apperead on the database, but i got the following errors. Connection.php line 664: SQLSTATE[HY000]: General error: 1825 Failed to add the foreign key constraint on table 'order_driver'. Incorrect options in FOREIGN KEY constraint 'forge/order_driver_deliverer_id_foreign' (SQL: alter table `order_driver` add constraint `order_driver_deliverer_id_foreign` foreign key (`deliverer_id`) references `users` (`id`) on delete NO ACTION) PDOStatement.php line 143: SQLSTATE[HY000]: General error: 1825 Failed to add the foreign key constraint on table 'order_driver'. Incorrect options in FOREIGN KEY constraint 'forge/order_driver_deliverer_id_foreign' PDOStatement.php line 141: SQLSTATE[HY000]: General error: 1825 Failed to add the foreign key constraint on table 'order_driver'. Incorrect options in FOREIGN KEY constraint 'forge/order_driver_deliverer_id_foreign' I ignored the errors and tried opening the project on my browser going to: https://laravel.test/FoodDelivery/public/ and i got the following error: "Whoops, looks like something went wrong." Is something missing? what else do i need to fix?
  2. harry_ord

    Downloading and installing a Laravel project from github

    This is my MySQL version: C:\xampp\mysql\bin>mysql -h localhost -V mysql Ver 15.1 Distrib 10.1.24-MariaDB, for Win32 (AMD64)
  3. harry_ord

    Downloading and installing a Laravel project from github

    I made a phpinfo.php file with: <?php phpinfo(); ?> And the page header says PHP Version 7.1.6 in bold. Could you try download it and install it yourself? i'm suspecting that the app is not actually working.
  4. harry_ord

    Downloading and installing a Laravel project from github

    I got this: Fatal error: Uncaught ReflectionException: Class config does not exist in C:\xampp\htdocs\FoodDelivery\vendor\laravel\framework\src\Illuminate\Container\Container.php:752 Stack trace: #0 C:\xampp\htdocs\FoodDelivery\vendor\laravel\framework\src\Illuminate\Container\Container.php(752): ReflectionClass->__construct('config') #1 C:\xampp\htdocs\FoodDelivery\vendor\laravel\framework\src\Illuminate\Container\Container.php(631): Illuminate\Container\Container->build('config') #2 C:\xampp\htdocs\FoodDelivery\vendor\laravel\framework\src\Illuminate\Container\Container.php(586): Illuminate\Container\Container->resolve('config', Array) #3 C:\xampp\htdocs\FoodDelivery\vendor\laravel\framework\src\Illuminate\Foundation\Application.php(732): Illuminate\Container\Container->make('config', Array) #4 C:\xampp\htdocs\FoodDelivery\vendor\laravel\framework\src\Illuminate\Foundation\helpers.php(110): Illuminate\Foundation\Application->make('config', Array) #5 C:\xampp\htdocs\FoodDelivery\vendor\laravel\framework\src\Illuminate\Foundation\hel in C:\xampp\htdocs\FoodDelivery\vendor\laravel\framework\src\Illuminate\Container\Container.php on line 752
  5. harry_ord

    Downloading and installing a Laravel project from github

    I checked and i have version 7.1.6 Where can i see the error log?
  6. I have a Laravel installation in Xampp and i configured a virtualhost with the url "http://laravel.test" so i don't have to write "http://localhost/laravel5-upaetest/public/". The problem is that now whenever i write the url "http:laravel.test" in my browser it takes me to the root of the htdocs folder and when i write "localhost" it takes me to my laravel project folder. How can i fix it? the idea is that when write laravel.test it takes me to my project in laravel5-upaetest/public. This is my httpd-vhosts.conf file: # Virtual Hosts # # Required modules: mod_log_config # If you want to maintain multiple domains/hostnames on your # machine you can setup VirtualHost containers for them. Most configurations # use only name-based virtual hosts so the server doesn't need to worry about # IP addresses. This is indicated by the asterisks in the directives below. # # Please see the documentation at # <URL:http://httpd.apache.org/docs/2.4/vhosts/> # for further details before you try to setup virtual hosts. # # You may use the command line option '-S' to verify your virtual host # configuration. # # Use name-based virtual hosting. # ##NameVirtualHost *:80 # # VirtualHost example: # Almost any Apache directive may go into a VirtualHost container. # The first VirtualHost section is used for all requests that do not # match a ##ServerName or ##ServerAlias in any <VirtualHost> block. # ##<VirtualHost *:80> ##ServerAdmin webmaster@dummy-host.example.com ##DocumentRoot "C:/xampp/htdocs/dummy-host.example.com" ##ServerName dummy-host.example.com ##ServerAlias www.dummy-host.example.com ##ErrorLog "logs/dummy-host.example.com-error.log" ##CustomLog "logs/dummy-host.example.com-access.log" common ##</VirtualHost> ##<VirtualHost *:80> ##ServerAdmin webmaster@dummy-host2.example.com ##DocumentRoot "C:/xampp/htdocs/dummy-host2.example.com" ##ServerName dummy-host2.example.com ##ErrorLog "logs/dummy-host2.example.com-error.log" ##CustomLog "logs/dummy-host2.example.com-access.log" common ##</VirtualHost> <Directory c:/xampp> AllowOverride All Require all granted Allow from all </Directory> <VirtualHost *:80> DocumentRoot c:/xampp/htdocs/laravel5-upaetest/public ServerName laravel.test </VirtualHost>
  7. Hello I have a WordPress site and i'm using the YOAST plugin to change the description that appears on Google. Yoast give me the option to change this on every page, but it doesn't seem to work. Here's a picture where you can see what i'm talking about: Is something missing? do i need to do something else?
  8. Hello This is my site: http://negociovirtual.cl/ I'm using the Divi theme and i have a section with a video background. The theme allows me to load a .mp4 and a .webm file, but not a .ogg file (maybe that's the issue?). I can see the video with no problem in Chrome, but in Firefox the video doesn't load and just give a black background. How can i fix this? I read online that you can solve the problem adding this to the .htacess file, but it didn't fix the problem: AddType video/ogg .ogv AddType video/mp4 .mp4 AddType video/webm .webm
  9. harry_ord

    input[type="button"] has style on Chrome but not on Firefox

    Ok, so i did another inspection, now on Firefox, i identified the element whose style i wanted to change and it was the class wpcf7-submit. So i added this to my custom css and now it's working: .wpcf7-submit { color: #ffffff !important; background: #014780; border-width: 1px !important; border-color: rgba(93,182,46,0.03); letter-spacing: 0px; font-size: 16px; font-family: 'Roboto', Helvetica, Arial, Lucida, sans-serif !important; padding-left: 0.7em; padding-right: 2em; padding: 0.3em 1em !important; display: inline-block; margin: 0 0 0 15px; font-family: inherit; cursor: pointer; float: right; padding: 0.3em 1em; border: 2px solid; -webkit-border-radius: 3px; -moz-border-radius: 3px; border-radius: 3px; font-size: 20px; font-weight: 500; line-height: 1.7em !important; -webkit-transition: all 0.2s; -moz-transition: all 0.2s; transition: all 0.2s; } Moral of the story: always try to do everything yourself. I copied the style from other site made by other person with the same WordPress theme. For being lazy i finished working more.
  10. Hello, this is my site: https://www.centrovision.com.gt/#contactanos I have a contact form here with a blue submit button. Actually, only if you are using Chrome the button is blue, if you are using Firefox or Internet Explorer, you just get a default no-style html button. Why doesn't Firefox comply with my css?(i don't care about i.e). Here's my css for the button: input[type="button" i], input[type="submit" i], input[type="reset" i], input[type="file" i]::-webkit-file-upload-button, button { color: #ffffff !important; background: #014780; border-width: 1px !important; border-color: rgba(93,182,46,0.03); letter-spacing: 0px; font-size: 16px; font-family: 'Roboto', Helvetica, Arial, Lucida, sans-serif !important; padding-left: 0.7em; padding-right: 2em; padding: 0.3em 1em !important; display: inline-block; margin: 0 0 0 15px; font-family: inherit; cursor: pointer; float: right; padding: 0.3em 1em; border: 2px solid; -webkit-border-radius: 3px; -moz-border-radius: 3px; border-radius: 3px; font-size: 20px; font-weight: 500; line-height: 1.7em !important; -webkit-transition: all 0.2s; -moz-transition: all 0.2s; transition: all 0.2s; }
  11. harry_ord

    input[type="button"] has style on Chrome but not on Firefox

    I don't know, i just used the inspect element and copy/paste the code in my theme's custom CSS and replaced the background color for the color i wanted. I deleted the "i"s and the button lost its color. The "i"s are necesary.
  12. harry_ord

    Displaying header data on google

    Sorry if this isn't the correct board for asking this question. This is my site: http://www.armonisencia.cl/site/ When you search "armonisencia" on Google, it displays the following (you can see it on the attached picture too): "Fatal error: Uncaught Error: Call to undefined function ... www.armonisencia.cl/site/ Traducir esta páginaFatal error: Uncaught Error: Call to undefined function elegant_description() in /home/armonisencia/public_html/site/wp-content/themes/DIVI/header.php:16 Stack trace: #0 /home/armonisencia/public_html/site/wp-includes/template.php(688): require_once() #1 ..." Maybe is some bug in my WordPress or something, but i decided i didn't want to look for the solution and i prefered to do the more simple stuff, i just edited my theme's header.php file and left the head element like this: <head> <title>Armonisencia</title> <meta charset="UTF-8"> <meta name="description" content="Naturaleza que funciona"> <meta name="keywords" content="Productos, Armonisencia"> <?php $template_directory_uri = get_template_directory_uri(); ?> <!--[if lt IE 9]> <script src="<?php echo esc_url( $template_directory_uri . '/js/html5.js"' ); ?>" type="text/javascript"></script> <![endif]--> <script type="text/javascript"> document.documentElement.className = 'js'; </script> <?php wp_head(); ?> </head> I made this change yesterday and today Google is still showing me the same ulgy data. How can i fix it?
  13. harry_ord

    Displaying header data on google

    Ok! now is displaying better stuff, but still doesn't show what i specified in the Yoast Plugin. I can't see my "HOLA MUNDO" yet, but at least is better than "FATAL ERROR".
  14. harry_ord

    Displaying header data on google

    Oh, it could be that. I hope so.(;・∀・)
  15. harry_ord

    Displaying header data on google

    But what do i do now? i don't know how to solve the error, because i left the header how it was, the error will keep appearing.
  16. harry_ord

    Displaying header data on google

    I left the header.php file how it was and now i am how i was in the beginning. What do i do now? the source code is showing the information provided in the Yoast SEO plugin, but the Google excerpt is still saying that can find the functions from the theme.
  17. harry_ord

    Accordion script doesn't work on mobile

    Problem solved. This is the story: I'm using the page builder that comes with the Divi Wordpress' theme and for being tidy i created every accordion item in a separated "text element" that caused me the trouble. What i did to solve it: I used just 1 text element and i put all the html there and now is working well. So i shouldn't trust those page builders?
  18. Hello This is my page: http://www.armonisencia.cl/site/puntos-de-venta/ In this page i'm using an accordion made in Javascript that i got from here: In desktop mode functions flawlessly, but when i shrink the nav window, some of the accodin headings become unclickable. If i put less items and try again, it works on a small scren, so i believe that the accordions are overlapping each other somehow and that's why maybe this is more a css issue than a Javascript issue so i didn't know where to post this. So, can you help me display this accordion on mobile devices?
  19. Hello This is my page: http://www.armonisencia.cl/site/puntos-de-venta/ As you can see, below each "region" you have a gruopu of tabs that when you clik on any of them, they will show you a hidden div. The problem is that when i'm watching the page on my home, only the first tab of each group works and the others don't respond when i push them. What i'm doing wrong? Here's the code: <script> var accItem = document.getElementsByClassName('accordionItem'); var accHD = document.getElementsByClassName('accordionItemHeading'); for (i = 0; i < accHD.length; i++) { accHD[i].addEventListener('click', toggleItem, false); } function toggleItem() { var itemClass = this.parentNode.className; for (i = 0; i < accItem.length; i++) { accItem[i].className = 'accordionItem close'; } if (itemClass == 'accordionItem close') { this.parentNode.className = 'accordionItem open'; } } </script>
  20. harry_ord

    Accordion effect doesn't work on mobile

    @media (max-width: 600px) { .et_pb_column { float: none; position: relative; background-position: center; background-size: cover; width: 100%; } } It doesn't work.
  21. harry_ord

    Woocommerce product list spacing

    Hello This is my site: http://www.armonisencia.cl/site/ I have a woocommerce product list and after that, i have a really long margin at the bottom. I'm trying to change it with css here: .woocommerce .products ul, .woocommerce ul.products { margin-bottom: 0; padding-bottom: 0; } But this doesn't seem to work, like only kind of works if a shrink my Chrome's window. Any idea how to fix it?
  22. harry_ord

    CSS accordion

    Hello I want to put an accordion-like menu on my site. Looking on Google i came across this: https://codepen.io/raubaca/pen/PZzpVe So i tried to use it on my site here: http://www.armonisencia.cl/site/puntos-de-venta/ I like how when you put the input type as"select" in the tabs, they toggle open/close when you click them, but if you click another tab when you have one open, the first one keeps open. I wish it closed itself. By the other hand, i you put the input type as "radio" in the tabs, every time you lick on one of them, this opens and the others close. But you can close the open tab clicking it again. I wish i could have both effect in one. How can i do it?
  23. harry_ord

    CSS accordion

    with it, i just used Javascript at the end: https://codepen.io/sureshrkm/pen/ZbzBpr Here is implemented at my site (at the bottom): http://www.armonisencia.cl/site/puntos-de-venta/
  24. harry_ord

    CSS accordion

    I'm not putting those <br> myself something is generatin them. This is my code: <div class="tab"><input id="tab-one" name="tabs" type="radio"> <label for="tab-one">PROVIDENCIA</label> <div class="tab-content" > <h4 class="subtitulo">Aldea Nativa Tobalaba</h4> <iframe src="https://www.google.com/maps/embed?pb=!1m18!1m12!1m3!1d3329.7643286413904!2d-70.58987878480131!3d-33.429388080780015!2m3!1f0!2f0!3f0!3m2!1i1024!2i768!4f13.1!3m3!1m2!1s0x9662cf0f3918e921%3A0x8ccee82ada4d5845!2sTobalaba+1799%2C+Providencia%2C+Regi%C3%B3n+Metropolitana!5e0!3m2!1ses!2scl!4v1507233683497" width="550" height="225" frameborder="0" style="border:0" allowfullscreen></iframe> <h4 class="subtitulo">Bow Spa</h4> <iframe src="https://www.google.com/maps/embed?pb=!1m18!1m12!1m3!1d3329.3185957576798!2d-70.61504988518345!3d-33.44100518077667!2m3!1f0!2f0!3f0!3m2!1i1024!2i768!4f13.1!3m3!1m2!1s0x9662cf789181ed05%3A0xa9aaf7e364430541!2sAntonio+Varas+1540%2C+Providencia%2C+Regi%C3%B3n+Metropolitana!5e0!3m2!1ses!2scl!4v1507235865077" width="550" height="225" frameborder="0" style="border:0" allowfullscreen></iframe> <h4 class="subtitulo">Mermoz Providencia</h4> <iframe src="https://www.google.com/maps/embed?pb=!1m18!1m12!1m3!1d3330.11334590174!2d-70.60863198518412!3d-33.42028918078254!2m3!1f0!2f0!3f0!3m2!1i1024!2i768!4f13.1!3m3!1m2!1s0x9662cf69040fa573%3A0x23907b0f170fd4f8!2sAv.+Providencia+2368%2C+Providencia%2C+Regi%C3%B3n+Metropolitana!5e0!3m2!1ses!2scl!4v1507236117341" width="550" height="225" frameborder="0" style="border:0" allowfullscreen></iframe> <h4 class="subtitulo">Dellanatura Mall Vivo Panoramico</h4> <iframe src="https://www.google.com/maps/embed?pb=!1m18!1m12!1m3!1d3329.9918827394267!2d-70.61220768518406!3d-33.423455980781526!2m3!1f0!2f0!3f0!3m2!1i1024!2i768!4f13.1!3m3!1m2!1s0x9662cf65fc43b5e9%3A0x891eec39c901980b!2sDellanatura!5e0!3m2!1ses!2scl!4v1507236369461" width="550" height="225" frameborder="0" style="border:0" allowfullscreen></iframe> </div> </div>
  25. harry_ord

    CSS accordion

    How can i make the icons appear then? i don't know why they don't appear on my site.
×