Jump to content

jane

Members
  • Content Count

    16
  • Joined

  • Last visited

Everything posted by jane

  1. Thank you very much. I don't have a remote server yet. I saw there are so many web hosting servers advertising online. Would you please recommend a good one so that I can have a try? Thanks.
  2. Thank you for your response. I tried comcast.net account. Still, cannot get mail from the online form submitted by php mail(). So I think I need to upload the files to a remote server to test it. I don't think the local SMTP server I downloaded works.
  3. I am learning PHP dynamic feature.I downloaded a free SMTP server from http://www.softstack.com/freesmtp.html. After filling out the form of contact.php ( an online form I made), I hit submit. The mail got through with no warning. But I could not receive the mail in my yahoo mailbox.Could anyone please recommend a good remote server that I can test the php mail(), or any good SMTP server?If I use a remote server, do I need to change the php.ini's "SMTP=localhost" to sth. else?Any input is greatly appreciated.
  4. jane

    mail() failed.

    Thank you very much. Today, strange enough. All the php mail() went through with the original free SMTP server. I did not change anything, except once in a while Mcafee did some automatic upgrades.The only exception is in <?php$to="someone@yahoo.com";$subject=$_REQUEST["subject"];$email=$_REQUEST["email"];$message=$_REQUEST["message"];mail($to, $subject, $message, "From: $email");echo "Mail sent";?>$to and $email cannot be exactly the same email address, like both are someone@yahoo.com. If both are the same, the mail still went through without error, just I cannot receive the self-mailed mail in my yahoo account. If one is a@yahoo.com, another is b@yahoo.com or b@comcast.net, the mail would go through, and I could get all the mails in my yahoo account.
  5. jane

    mail() failed.

    The technical support at Softstack asked me to try their First SMTP Server. I tried but still got the same error. I open the cmd window,typed "telnet localhost 25", it came out: "220 Welcome to ESMTP Server".typed "mail from sb@yahoo.com, came out "250 Ok"typed "rcpt to sb@yahoo.com, came out "250 Ok"typed "data", came out "354 Enter mail, end with "." on a line by itself"typed "subject: test email This is just a test." came out "250 Ok"typed "quit", came out "221 Closing transmission channel Connection to host lost"The mail() did work previously after I installed SMTP server, now it does not work. Between then and now, I upgraded the McaFee Security Center, upgrade IE from 6 to 7 beta. But I am now only using firefox browser since it's faster. I doubt the problem might come from Mcafee. But how to resolve it? Thank you very much.
  6. jane

    mail() failed.

    I tried your suggestion, still failed with the same error message. The mail() did work after I installed SMTP free server. Now it does not work. I forgot what I have done between then and now. I just sent an email reporting my problem to the softstack link you gave me. Hope the problem would be resolved soon.Thank you very much.
  7. jane

    mail() failed.

    Thanks.In cmd, after I typed "telnet localhost 25", I got "220 localhost". So the computer accepts connection at port 25. In php.ini, I searched SMTP, and found the line as "SMTP = localhost".
  8. jane

    mail() failed.

    I used the following code to get email from an html form.<?php$to="someone@yahoo.com";$subject=$_REQUEST["subject"];$email=$_REQUEST["email"];$message=$_REQUEST["message"];mail($to, $subject, $message, "From: $email");echo "Mail sent";?>It came out the error:Warning: mail() [function.mail]: Failed to connect to mailserver at "localhost" port 25, verify your "SMTP" and "smtp_port" setting in php.ini or use ini_set() in E:\Documents and Settings\My Documents\My Web Pages\phpfile.php on line 160I came across this problem before. Then I downloaded a free SMTP server from www.softstack.com, and the mail went through. Now, I came up with the same problem again. I turned on the free SMTP, it still did not work. I don't have a commercial web server, all my files are under localhost. I downloaded the php, apache, and mysql from wamp5. So do I need to check some .ini file for this? Or is it better to use asp for sending email?Thank you very much.
  9. Thanks.I can see this image. But I cannot see all other examples. For the last example flash. I can see both flashes on IE, but cannot on firefox.
  10. Thanks.On page: http://www.w3schools.com/media/media_object.aspI can only display the picture after "click here to try it yourself", and cannot dispaly all the others.
  11. I like to use firefox browser, since it's faster. But I cannot see the multimedia results in firefox browser. It works properly on IE. Is there any way to resolve it so that I can see multimedia (sound and video) results also in firefox browser?Any input is GREATLY appreciated.
  12. The %20 does not work. Yes. If I put the image file to the same directory as my html file under my virtual host, the image is shown properly. Now I am clear!!! When I opened the html file through open->file->browse, I can see the image even if it's just <img src="E:\directory\file.html">. That's why I always saw the picture when I first learned html. Then I began to learn php. I installed php, apache, mysql on my machine. Today, I wanted to incorporate my previous html file with php to make it more dynamic. But this time, I opened the file through http:\\localhost\file.html, but I could not see the image.So when I opened the http:\\localhost\file.html, I actually accessed it through online, although only I can access the file. So in this way, I cannot use <img src="E:\directory\file.html">. Instead, I should upload the file to the directory under my virtual host.Thank you so much for your help.
  13. Thanks. I tried your suggestion, still no image shown. Yes, I open the file from my computer http://localhost/file.html
  14. Thank you very much.With file:\\\ or without still cannot make the image show up on the browser. I checked on both firefox 1.5.0.6 broswer and IE 7.0.5450.4. Usually I only use firefox since it's faster.
  15. Thank you very much for all the above replies. Now, I used the <img src="file:///E:/My Documents/My Pictures/2006_04_21/IMG_1575.JPG" width="300" height="200" />the picture is still not shown.The page is not online, it's only on my local computer.
  16. The image file IMG_1575.jpg is shown properly if I include it using <img src="IMG_1575.jpg" width="300 height="200" />. But if I include it with <img src="E:\My Documents\My Pictures\IMG_1575.JPG" width="300" height="200" />, the image is not shown in the browser. It's blank. How to resolve this? How to include a file on my local computer with direct path?Any input is GREATLY appreciated.
×
×
  • Create New...