Jump to content

Frames problem


murfitUK
 Share

Recommended Posts

I hope someone can help with a problem with frames.The site has a banner along the top, a contents menu down the left-hand side and a main frame. Its been created with FrontPage2000 and I have tested it with Firefox and Internet Explorer 6.When opened with FF or IE from my hard drive it works OK. Clicking on a menu item opens the page in the correct frame (the main frame).I've uploaded it to my webspace and this is where the problems start.If I access the index.htm page by clicking on a link it all works fine. But if I open the site by typing the address into the address bar it doesn't work - the initial page opens fine but clicking on a menu link will open the target page in the whole of the window. This happens with both FF and IE.The address is http://homepage.ntlworld.com/murfituk/shop/index.htmbut as I mentioned, if I click on this link it will work OK. I can't figure out why it works by clicking on the link but not if I type in the address manually.Please can someone point me in the right direction. Thanks for your help.

Link to comment
Share on other sites

The address is http://homepage.ntlworld.com/murfituk/shop/index.htmbut as I mentioned, if I click on this link it will work OK.  I can't figure out why it works by clicking on the link but not if I type in the address manually.
I just typed the address of your site into the address bar and everything worked fine, all pages opened in the targeted frame :)
Link to comment
Share on other sites

Just to be clear, you type this address into the browser address bar:http://homepage.ntlworld.com/murfituk/shop/index.htmThen when you click the navigation, instead of the page opening in the target frame it opens in the whole window :) This definently isn't happening for me (IE)

Link to comment
Share on other sites

Just to be clear, you type this address into the browser address bar:http://homepage.ntlworld.com/murfituk/shop/index.htmThen when you click the navigation, instead of the page opening in the target frame it opens in the whole window  :) This definently isn't happening for me (IE)

That's right. If I open FF or IE and type in the address & click Go, the page starts off fine but clicking the menu items opens the relevant page in the whole window and not the main frame.However, if I open the site by clicking on a link - eg the url in this thread - it all works fine. Clicking a menu item will display the relevant page in the main frame.Its exactly the same with FF or IE.
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...