Jump to content

Weird Flash Deployment Wmode Tag


djdawkins
 Share

Recommended Posts

HiI hope this is the right forum, as I know there is nothing wrong with the movie, just the code (he said confidently)Heres one for you....I have put a small flash movie with a transparent background into a new page and am trying to get it to look the same in all browsers. But it doesn't. I have done some tinkering with it as first it would show in IE then nothing else, then everything but IE. At the moment it show fine in IE7, Opera and Chrome, the background appears in Safari, and there is nothing at all showing in Firefox 2 or 3.at the moment the code is:

<object classid="clsid:d27cdb6e-ae6d-11cf-96b8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=7,0,0,0" width="506" height="170" id="gladys12" align="middle"><param name="movie" value="images/gladys12.swf" /><param name="quality" value="high" /><param name="wmode" value="transparent" /><param name="pluginurl" value="http://www.macromedia.com/go/getflashplayer"/>     </object>

i'm using xhtml transitional dtd. As i said, i fiddled with it a bit to get where I am now, which is the best it has been. I know that 90% of people use IE, but as i know some of the people going to use it favour FF, I want to get it sortedAll help greatly appreciated

Link to comment
Share on other sites

FF uses embed, which is inserted within the object, try:<object classid="clsid:d27cdb6e-ae6d-11cf-96b8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=7,0,0,0" width="506" height="170" id="gladys12" align="middle"><param name="movie" value="images/gladys12.swf" /><param name="quality" value="high" /><param name="wmode" value="transparent" /><param name="pluginurl" value="http://www.macromedia.com/go/getflashplayer"/><embed'>http://www.macromedia.com/go/getflashplayer"/><embed src="images/gladys12.swf" quality="high" pluginspage="http://www.macromedia.com/go/getflashplayer" type="application/x-shockwave-flash" width="506" height="170" wmode="transparent" name="gladys12"></embed></object>OH YAA....90% of people use IE, Microsoft wish see browser usage

Edited by dsonesuk
Link to comment
Share on other sites

FF uses embed, which is inserted within the object, try:<object classid="clsid:d27cdb6e-ae6d-11cf-96b8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=7,0,0,0" width="506" height="170" id="gladys12" align="middle"><param name="movie" value="images/gladys12.swf" /><param name="quality" value="high" /><param name="wmode" value="transparent" /><param name="pluginurl" value="http://www.macromedia.com/go/getflashplayer"/><embed'>http://www.macromedia.com/go/getflashplayer"/><embed src="images/gladys12.swf" quality="high" pluginspage="http://www.macromedia.com/go/getflashplayer" type="application/x-shockwave-flash" width="506" height="170" wmode="transparent" name="gladys12"></embed></object>
thanks thats fixed FireFox. I took the embed code out to start with, cannot remeber why now. i definitely cured something removing it!Still have a background appearing on Safari though. Any Offers?
Link to comment
Share on other sites

<embed> is not valid HTML. The correct cross-browser way to get a Flash document on the page is the following:

<object type="application/x-shockwave-flash" data="images/gladys12.swf" width="506" height="170" id="gladys12">  <param name="movie" value="images/gladys12.swf" />  <param name="quality" value="high" />  <param name="wmode" value="transparent" />  This content requires <a href="http://www.macromedia.com/go/getflashplayer">Flash Player</a> to be displayed.</object>

Link to comment
Share on other sites

if you want html validation the best option would be<object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" width="506" height="170"><param name="movie" value="images/gladys12.swf" /><param name="wmode" value="transparent" /><!--[if !IE]>--><object type="application/x-shockwave-flash"data="images/gladys12.swf"width="506"height="170"><param name="wmode" value="transparent" /><!--<![endif]--><!--[if !IE]>--></object><!--<![endif]--></object>OR you might want to consider using javascript to play a flash file instrudtions can be found here swfobject

Edited by dsonesuk
Link to comment
Share on other sites

there several ways of displaying flash content, a good site which lists quiet a few is http://perishablepress.com/press/2007/04/1...-or-die-trying/
That article is wrong:
Thus, we once again must reach out and coddle IE with its proprietary classid attribute
Internet Explorer does not require the classid attribute for Flash documents. This is why they had to make their code longer and more complex, because they did not try removing the classid attribute.
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...